Problem with Framework Update/Core 2.4.0beta1.2

Hi,

I get the following when trying to install the current updates.

Fatal error: Cannot instantiate non-existent class: ext_addqueuemember in /var/www/html/admin/modules/core/functions.inc.php on line 1188
1 error(s) occured, you should view the notification log on the dashboard or main screen to check for more details.

Thanks,
Chris

Asterisk 1.4.15

the upgrade of several modules failed with message about retrieve_conf failing, when i click on the orange bar. /var/log/httpd/error_log shows:

PHP Fatal error: Class ‘ext_setcallerpres’ not found in /var/www/html/admin/modules/core/functions.inc.php on line 1165

I’d installed this quite awhile ago, and the upgrades in question just now showed up as available…

the above error related to processing of agents/queues, which i don’t use. i found that deleting this line caused a new error to show up (a few lines later.) long story, there were maybe half-dozen such errors, all related to agents/queues. i deleted them and uninstalled the queues module and the reload went okay. obviously not the best fix, but i was leery of having my system borked…

did you install framework first? I’m being ‘slack’ in putting dependencies this early on as it clutters up the xml files, but you should be upgrading ALL modules, especially framework. If you did upgrade framework and still have these errors, please let me know. The required classes are defined and installed there and were added in the latest framework upgrade (or should have been).

I did, well, as part of the same update so I’m not sure if that counts?

is it still broke? are you upgraded to framework and still running into the same problem?

Correct - no matter what I try I cannot apply changes…

Can I force a framework upgrade to beta 1.1 somehow?

my deepest apologies to all. My build script was till pointing to trunk instead of 2.4 for framework so it was not grabbing the actual changes. Problem should be fixed now, go download the newest framework.

Philippe - no need for apologies - it’s a beta - stuff happens… remember who I work for and just think back to the quality software releases that we ‘produce’ … :wink:

Having said that - I now get:

PHP Fatal error: Cannot redeclare class ext_setcallerpres in /var/www/html/admin/modules/outgrps/functions.inc.php on line 44

But I also note in my Apache error log:

[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  value in /var/www/html/user/includes/xmlpex.php on line 73
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined index:  tab_text_constant in /var/www/html/user/index.php on line 15
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined variable: content in /var/www/html/user/includes/functions/functions.php on line 45
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Notice:  Undefined variable: content in /var/www/html/user/includes/functions/functions.php on line 45
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Warning:  include(modules/06_registrationTool/index.php) [<a href='function.include'>function.include</a>]: failed to open stream: No such file or directory in /var/www/html/user/templates_c/%%89^893^89324CCC%%mainUser.tpl.php on line 48
[Sun Dec 16 19:34:24 2007] [error] [client 192.168.1.24] PHP Warning:  include() [<a href='function.include'>function.include</a>]: Failed opening 'modules/06_registrationTool/index.php' for inclusion (include_path='.:/usr/share/pear') in /var/www/html/user/templates_c/%%89^893^89324CCC%%mainUser.tpl.php on line 48

I’m not sure if something else broke… or whether I’ve had a little too much festive cheer… :confused:

?

habile,
that is a problem with the outgrps module which is not even in our contributed repository as the author did not want to put it there last I pinged them (so I can’t help). Anyone who is extending classes like that in their modules should always be doing it in a “if not exists declare” type mode so that when the classes get put in, their module doesn’t break. You should contact the author and request they make the change.

Fair enough - how can I remove a module without the GUI? The GUI no longer comes up because of those errors posted…

Don’t worry - just removed the directory…/var/www/html/admin/modules/outgrps/ - seemed to do the trick.