Problem with database configuration

Hi -

I’m trying to install version 2.3.1 onto a Suse 10.1 machine that’s running asterisk v 1.4.9, MySQL 5.0 and PHP5.

I had a bunch of problems along the way mostly with paths and so on but now I’m really stumped.

The install almost completes but fails when attampting to update the MySQL databases as shown below. I have created the databases and given permission as per the INSTALL doc.

Any deas?


Configuring install for your environment…amportal…freepbx_engine…done
apply username/password changes to conf files…done
== Parsing ‘/etc/asterisk/manager.conf’: Found
Verbosity is at least 3
Setting permissions on files…OK
Checking for upgrades…20 found
Upgrading to 1.10.007beta1…
-> Running SQL script /home/hwaterfall/freepbx/freepbx-2.3.1/upgrades/1.10.007beta1/tables.sql
[FATAL] ALTER TABLE sip CHANGE id id BIGINT( 11 ) DEFAULT “-1” NOT NULL [nativecode=1146 ** Table ‘asterisk.sip’ doesn’t exist]" while running tables.sql

did you use the newinstall.sql script to create the initial database tables? install_amp does not do that (at this time).

DOH! I was looking at the INSTALL doc - how’d I miss THAT?!

Thanks for your help. Almost there now (I can feel it). One last glitch:

When I run amportal start it complains about not being able to start the FOP’s server as shown below. I’ve tried being logged in as root and as asterisk (all the files in /var/www/html/panel are owned by user/group asterisk).

Any ideas?


asterisk-dev:/var/www/html/panel # /usr/sbin/amportal start

Permissions OK

Asterisk Started

-su: line 0: cd: /var/www/html/panel: Permission denied
kill: no process ID specified
Try `kill --help’ for more information.

The FOP’s server ( could not start!
Please correct this problem

started a new thread for this as it’s no longer a database issue: