Problem connecting Cisco 8961 with Asterisk


(Alex Dietz82) #1

Hello,

I am trying to connect my Cisco CP-8961 with FW sip8961.9-4-2SR4-1 to Asterisk which is running on a Raspberry.

But i get tis Error
[ 1caa0710-a5e10006-2354ed4f-41cc5b4e(at)192.168.1.11) - Failed to authenticate
[2021-01-19 20:48:02] NOTICE[1178]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘<sip:82(at) 192.168.1.2>’ failed for ‘192.168.1.11:5060’ (callid: 1caa0710-a5e10006-2354ed4f-41cc5b4e(at) 192.168.1.11) - Failed to authenticate]

This is my SIP[MAC].cnf.xml

SIP admin PW 1 M/D/Y W. Europe Standard/Daylight Time pool.ntp.org Unicast 2000 5060 5061 192.168.1.2 5060 true true x-serviceuri-cfwdall x-cisco-serviceuri-pickup x-cisco-serviceuri-opickup x-cisco-serviceuri-gpickup x-cisco-serviceuri-meetme x-cisco-serviceuri-abbrdial false 2 true true 2 2 0 true 6 10 180 3600 5 120 120 5 500 4000 70 false None 1 false true false false 101 3 avt false false 3 Name 1 true 10 false 9 Phone Number USECALLMANAGER 5060 82 line1 2 3 82 PW false 1 *97 4 5 cisco8961 true false false true 5060 8000 59999 184 0 dialplan.xml true 2 sip8961.9-4-2SR4-1 false false 1 1 0 0 0 0 1 1,2,3,4,5,6,7 00:00 00:50 00:20 1 1 de_DE de_DE utf-8 1.0.0.0-1 2 96 0 96 2 0 3804 false

I Tried it with TLS, TCP and UDP. Every time only error.
I hope someone can help me further. I can’t find an answer via search engines.

Alex


#2

Confirm that in FreePBX you have created extension 82 as a pjsip (not chan_sip) extension.

Some devices are incompatible with the long autogenerated Secret. Choose a simple password consisting of no more than 12 letters and digits and paste that into both Secret for the extension and authPassword for the phone.

Many Cisco phones require that both Rewrite Contact and Force rport be set to No for the extension.

If you still have trouble, at the Asterisk command prompt, type
pjsip set logger on
reboot the phone, paste the Asterisk log for the registration attempt (including SIP trace) at pastebin.freepbx.org and post the link here.

Also, your XML file got butchered by the forum. Paste it at pastebin.freepbx.org and post that link as well.


(Alex Dietz82) #3

Thanks for the prompt help. It was indeed due to the password length.
Max. length is 12 digits for Cisco CP-8961

So, this Problem is solved!


(Dave Burgess) #4

I have heard reports, on and off, that using TCP instead of UDP can also help with some connection problems. If you run into any new connectivity problems, I’d suggest adding that to your mix.

Do not (since the system is working) do this unless you just want to mess with to see what it does.