Problem after upgrade

Once I upgraded using tarball, from freepbx 2.3.0 alpha to 2.4.0 and then then I go to module admin, I get the following error.

Module Administration
SELECT * FROM module_xml WHERE id = “xml” [nativecode=1054 ** Unknown column ‘id’ in ‘where clause’]SQL -
SELECT * FROM module_xml WHERE id = “xml”

I also did the following

cd /usr/src/freepbx-2.4.0
./install_amp --force-version=2.3.0

I still get the above error.

How to rectify this.
Thanks in advance.

Should I click on apply configuration changes before downloading and upgrading all the modules?

redo the tarball install, but add the following option:

–force-version 2.2.0

that will make sure that the required schema is upgraded. The error is related to having been on the alpha, it should have detected that but for some reason did not. Once you do that the error should go away, and then you should go into module admin and upgrade all appropriate modules.

Everything works but I can not see config edit module. It doesnot show up in installed or online modules available.

Just saw that it does not have Maintenance category. So nothing shows up, no A2billing, sysinfo, ConfigEdit and PhpMyadmin.

Infact Just tried http://192…/maint and then it shows me all the things in the [email protected] format.
Will this do any harm?

none of those are FreePBX modules, but if you had modules for them previously installed they should still be there.

What about ConfigEdit? That is a freepbx module, right?

nope - that’s what editors are for, and they usually do a much better job at it:-)