Previously working trunk settings stopped working

My provider, recently recovered from a DDoS attack.

Following the attack, trunks would not register using the previous PJSIP settings that worked, ie filling in only the fields under Trunk PJSIP settings, General tab: [Username] [Auth username] [Secret] [SIP Server], leaving everything else at default or blank.

Outbound calls would not go through due to trunk unavailable, and inbound calls would not be delivered because registration failed.

After contacting VoIP Much customer service, and going through an entire day of troubleshooting, we found that outbound calling could be restored by filling in the following fields on the Trunk PJSIP Settings Advanced Tab:

We then discovered that inbound calls would not come in (not registered.) After much experimenting, we came up with the following workaround:

  1. delete affected trunk
  2. reboot
  3. add PJSIP trunk with only PJSIP Settings General fields:
  4. [Username] 317XXXXXX
  5. [Auth username] 317XXXXXX
  6. [Secret] ##passwordsuppliedbyvoipmuch##
  7. [SIP Server]
  8. [Transport]
  9. test inbound calling IF THIS STEP DOES NOT PASS, START OVER
  10. under Trunk PJSIP Settings Advanced tab fill in the following fields:
  11. [From Domain]
  12. [From User] 317XXXXXX
  13. [Client URI] [email protected]
  14. [Server URI] [email protected]
  15. test outbound calling
  16. if PBX has to be rebooted, erase fields: [From Domain] [From User] [Client URI] [Server URI] and repeat procedure from step 9.

I wonder if anyone else has encountered this issue, and if so, what is the cause?


From domain is your IP address not your providers

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.