Post-Restore Hook does not find the script [SOLVED]


(Claudio Pelosi) #1

Freepbx 13
I am trying to run a script in Post-Restore Hook but it does not find the file yet I put it both in the main dir / var / spool / asterisk / backup and in the specific dir of the backup, the rights are 777 and I gave asterisk owner. …
I saw some ducumentation but for version 15
https://wiki.freepbx.org/display/FOP/Hooking+Backup+through+an+external+script


(Claudio Pelosi) #2

I also put the script in the home … / home / asterisk
I also put the script in / var / spool / asterisk / backup /
i put the execution rights and i put asterisk as owner
I don’t know what to invent anymore …


(Claudio Pelosi) #3

When I perform the procedure here is how it responds:
Running post restore script…
sh: ripristino: command not found


#4

Perhaps try putting the script in /var/lib/asterisk/bin/


(Claudio Pelosi) #5

Solved
basically i used directory / home / asterisk / backup and gave execute rights

so i run the script correctly


(Claudio Pelosi) #6

The problem was in how I set up asterisk backup Warmspare I didn’t know how to use Warmspare well and it gave problems before it called my code …


(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.