Possible to use VoIP extension as a Trunk for placing calls?

siptrunk
Tags: #<Tag:0x00007f702737d978>

(Drtech) #1

I have a residential FTTH connection, and I get free phone service, which is delivered by using the inbuilt VoIP gateway on my Huawei HG8145v GPON modem.

I have access my SIP Server address, username, password, extension and possible many other settings that I don’t consider so much relevant, using which I can configure a SIP soft phone such as MicroSIP or Zoiper to place and receive calls on my desktop.

I was wondering if there’s a way to use that SIP extension as an outbound & inbound trunk on my FreePBX setup for placing and receiving calls ?


(Reinhard Stindl) #2

If you can configure a SIP phone to connect to your Huawei modem than you can configure a freePBX trunk to connect to it too…


(Drtech) #3

Yes, but how ? What settings should I configure in FreePBX ?


(Reinhard Stindl) #4

You create a SIP trunk in freePBX…using the username, password and server address you already tested with your sip soft phone.


(Drtech) #5

So I created a Trunk with the following settings :



However, I can not place any outbound calls, nor am I able to receive any calls.

I can successfully ping my ISP’s VoIP server.


(Reinhard Stindl) #6

I thought your modem is part of your intranet…and I thought you can configure a Huawei voip extension. Your username and password look very weird…are you sure you need the @-part?

Anyway you could check, if your trunk is online Reports>Asterisk Info>Peers


#7

What does Reports -> Asterisk Info -> Registries show?

Please post the settings you successfully used in Zoiper (list all settings that you changed from the default) and we can try to provide an equivalent for FreePBX.


(Drtech) #8

MicroSIP settings are as follows :

FreePBX Asterisk > Registries :

I am also confused since my register string is having 3 ‘@’ characters, maybe that is making things not work ?


#9

I believe you are correct but unfortunately the documentation isn’t very good. We have to take this one step at a time, first getting it to register, then trying to make and receive calls. When you test this, be sure to close MicroSIP; the provider may not allow more than one device at the same time.

I can think of three approaches, First, try this register string:

+915324000xx@ims.airtel.in@ims.airtel.in:Huawei@1@10.232.142.146/+915324000xx

If it shows Registered, edit the Peer Details:

fromdomain=ims.airtel.in
username=+915324000xx@ims.airtel.in
fromuser=+915324000xx@ims.airtel.in

leave other settings as they are.

If this fails, report results and we’ll decide whether another approach is needed.


(Drtech) #10

Tried this, still not registering.


(Reinhard Stindl) #11

Try to replace the @ with %40 in username and password of the register string as described in this threat

Test your original register string (your third posting with the screenshot) first and just replace 2x@


#12

Just for laughs, I put this into MicroSIP:


and was astonished to find that it sent:

REGISTER sip:10.232.142.146 SIP/2.0
Via: SIP/2.0/UDP 192.168.4.78:55015;rport;branch=z9hG4bKPjbd6a7ff3acb84400856c2256d176d373
Max-Forwards: 70
From: <sip:+9122233344444@ims.airtel.in>;tag=83fc8ae46ad44e708636d11e79289a9d
To: <sip:+9122233344444@ims.airtel.in>
Call-ID: 78551949de1f4ef4bdd1ef38a60dd8e8
CSeq: 29994 REGISTER
User-Agent: MicroSIP/3.20.0
Contact: <sip:+9122233344444@192.168.4.78:55015;ob>
Expires: 300
Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
Content-Length:  0

I have no idea why it would do this!

If your MicroSIP does the same thing (and it works), your corresponding register string would be:
+915324000xx@ims.airtel.in:Huawei@1:+915324000xx@ims.airtel.in@10.232.142.146/+91532400xx

If this still fails to register, please post SIP trace of successful registration from MicroSIP log, as well as SIP trace from Asterisk for the failed registration. At the Asterisk command prompt, type
sip set debug on
and the SIP trace will be included in the regular Asterisk log.


(system) closed #13

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.