PORTech MV-370 Mobile VoIP - Incomming Calls

I have a PORTech MV-370 Mobile VoIP Gateway, which I have set up as a SIP Trunk in FreePBX. I have it making outgoing calls just fine, but I don’t know how to configure it for incomming calls.

I have the Mobile to LAN set to forward * to 500, Realm 1 is configured to forward to my PBX and shows up as Registered. The incomming settings under the SIP Trunk configuration page on FreePBX I have set as:

secret=500
type=user
context=from-trunk

The user context is “ING” (i just made that up).

When I view the FOP, both OUTG and ING show up under trunks and are green. When I call the mobile number it seems to hang up on me. outgoing on OUTG works fine but I can’t get incomming to work.

Anyone know anything about this?

I have the Portech MV-370 working inbound and outbound, details here:
http://samyantoun.50webs.com/asterisk/freepbx/portechmv370

Hope this helps

Can you explain the “Mobile To Lan Settings”, the 7777 you have, is that the SIP extention that the box logs on to or it is the ringgroup code that its supposed to call? I’m assuming it’s the number of the ring group and your SIP extention of the gsm box is 85858585.

I don’t see the setting Mobile > Settings > Mobile > Band Type… hmm

Also, you told me the FreePBX > SIP Trunk > Outgoing Settings, what do I set under FreePBX > SIP Trunk > Incomming Settings for “USER Context” and “USER Details”?

Thanks.

  1. No Extension or ring group required (I think 7777 is one of the FreePBX pre-defined feature codes)

  2. Mobile > Settings > Mobile > Band Type = 900/1800 MHz

  3. Both “USER Context” and “USER Details” in SIP Trunk > Incomming Settings are Blank

  1. I’ve set the Mobile to LAN settings to 0, *, 7777, you’re right, 7777 is defined in FreePBX as simulate incomming call.

  2. I don’t want to sound stupid but I can’t find that setting, here’s a screenshot in my settings: http://leechristie.com/hotlinks/mobile.png My box is a Quad-simcom Band according to the bottom of the unit (I don’t know what that meens though), could that affect it?

  3. Okay I’ve blanked that now.

Still doesn’t work. :frowning:

Change 7777 with [email protected]
Also I recommend you to download the latest firmware from portech.com.tw

Okay I’ve tried [email protected] and I have the latest firmware but it’s still the same.

You need to allow anonymous calls to your PBX in General Settings or need to register your MV370 as an extension on your PBX for this to work.

SPAM

I have failed to configure my incoming calls on PORTech MV-370 too. It is a real pain to configure it. You should use google, I think you will find the decision there, because I do. I just can remember it now, but on the first page of google you will find some nice tips.

Sincerely,

Steven Barrot from mobile application development

I defined MV-370 as an extension for my FreePBX and it registered and seems to be working.
All attempts to register it as a trunk were failed.

I’ve got my MV-0372 working. Inbound calls go to queue and outbound calls work ok.
Had some problems, but then upgraded firmware and now i have it registered as a trunk.

But the latency is the problem:

1001/1001 172.16.0.65 D N 5060 OK (327 ms)

When the mobile user calling for outside to MV-372 disconnects the call, Asterisk still keeps ringing for 3-5 sec.

Anyone with similar problems?

Thank you

Just thought i would write my set up so to help others with the same hardware

I have the Gateway registered as a normal extension for each SIM, then for each extension i have a custom trunk added that matches a custom number and dials SIP/(number to dial)@(GSM Ext)

Hi,

can anyone share your settings in MV-370(372)?
I’m now configure my MV-372 as sip-trunk, but it cannot use the plugin “custom context” to work (it can only working in extension)

another question is my incoming calls from MV-372’s sip trunk cannot pass the DTFM number when the caller already listen the IVR, the IVR will timeout anyway …

thanks in advance