Polycom VVX600 Call Pickup

I’m trying to figure out and issue with Polycom VVX series endpoints not able to perform pickup on another incoming call from a BLF. The BLF line shows an incoming call, so I press the line button and hold until ‘pickup’ appears. I select the pickup option, and the phone dials a single ‘*’ and stops. If I manually dial '**", the call is picked up. This is working fine on other devices, such as a Yealink T48G.

This is on FreePBX hosted on PowerPBX. I’m using EPM for provisioning. Oh, and I’m pretty new to FreePBX.


I don’t hold anything down and select pickup or anything like that when I have a blf that is indicating a ringing state.

I simply press the blinking blf like normal and the call is picked up as expected.

What happens age I simply just press the blinking blf for just a second like normal?? Not holding it down not waiting for anything to display.

Just tested, exact same experience with simple touch. One ‘*’ gets dialed.

Have you figure out the solution to this?

No, I marked it up as a bug and never revisited. I presume you are asking because you are still seeing similar behavior?

Hi Matt,

Thanks for your reply! Yes, one of my user mentioned that the window pops up whenever there is inbound call to one of BLF line, and when he pressed “Pickedup” button, it directed to his voicemail.

I soon figured out the reason for the voicemail is due to the setting of call.directedCallPickupString="*97" by default.

By following below instruction, I changed that parameters to "**" or "*8", added notifycid=yes in sip_general_custom.conf, etc…, but so far no luck.

Interesting thing is that GrandStream GXP2170 can pickup the line just by pressing BLF button.

Just for the sanity check, I updated the firmware of VVX601 to the latest 5.9.0, but no change. I am still unsure about dialog-info+xml method which was described in above FAQ, I was just curious whether anyone successfully implement BLF call pickup feature or not.

Perhaps as you mention, I should suppress popup window by setting attendant.behaviors.display.spontaneousCallAppearances.normal="0" so that user won’t be bothered with popup window…

@domosute Please stop replying to old threads and doing it in multiple threads. You posted this issue in another thread and I asked for the settings you were using in that thread. Please stick to one thread and if you have an issue that you can’t find a current thread for, open a fresh one and not ones that are multiple years old.

Hi Tom,
Thanks for your suggestion.

My solution at the time was to swap the device with a Yealink T48G, had no issues with call pickup on those devices. Just some specific issue with Polycom devices. After that, I hadn’t really revisited it.

1 Like

Thanks Matt, and sorry for reopening old thread.
If I find any solution, I will create new thread and let you know! :slight_smile: