Polycom VVX450 registration

Hey I’m guessing/hoping this is something simple that I’m just doing wrong.

We have a FreePBX Server (v16.0.40.7) and a bunch of random old Aastra/Mitel, Grandstream, and Cisco phones. One of my extensions recently has been having issues with his phone, a Grandstream, where incoming calls are going straight to voicemail. I did some troubleshooting with it but eventually I couldn’t even get into the webUI for the phone so I figured, hell, I’ll just get him a new phone. Since I was out of spares I thought, well, I’ll just grab a newer, nicer phone while I’m at it. I have experience with VVX410s from a previous job, so I got a used VVX450 from eBay.

The phone itself seems really nice, I was able to set it to take the static IP the old phone had at our firewall, so it powers up and gets IP and everything. I’m able to log in to its WebUI, and do some configurations on it that are working; time and set are set (so it has internet connectivity), line label is set, etc.

However, I cannot get the thing to actually register to my FreePBX server. I’ve tried to replicate settings from a working (non-Polycom) phone, but I just get the “Provisioning Failed” notice with the little red X next to the line.

I feel like I’m just spinning my wheels here, any idea on how to troubleshoot this?


If you are wanting to have the phone provision from your PBX you need to generate the configuration files that it will download, either manually or through the Endpoint Manager inside of FreePBX.

That would be nice to set up at some point so that phones do automatically provision, but all the phones we have right now I have to log into the webUI and set the sip server, port, proxy port, outbound proxy port, the number/xt, password, etc and they just register that way.

I’ll take a look at the endpoint manager in FreePBX but right now I’m really just concerned with getting this phone to register manually

And actually - looking in Endpoint Manager, I don’t currently have the license for this, so it won’t work with this phone anyway. Though I am definitely interested in getting that and setting up automated provisioning at some point

There is an open-source version you might be able to use.

PBX GUI : OSS End Point Manager (sangoma.com)

As for the Poly phone, there’s no reason is shouldn’t be able to register as a SIP19 device. Maybe you can share your manual configuration steps and screen shots? We might be able to see the miss from there.

What is your SIP port?
IS the phone on the same subnet as FreePBX
Do you see the registration attempt from the FreePBX logs?

Of you are setting through the web make sure you don’t have an ip/url in the provisioning menu

I figured it out - it was DNS. It’s always DNS!

The phone wasn’t able to ping the PBX. Changed its IP, that fixed it and it started working. Changed the IP back, power cycled the pbx server, and everything is fine now.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.