Polycom Time / Provisioning

Hello all. Running FreePBX distro, asterisk 11, and Polycom VVX400 phones. I’m having issues with provisioning.

The time on our phones is off by 1 hour. The sip.cfg has these settings:

These settings are what we want. The phone configs do not reflect this. I can see that our phones are downloading the configs by monitoring TFTP traffic, specifically they grab sip.cfg.

But still, the time is off on the phones. Looking at the web config on the phones, I don’t see any entries under Preferences->Date & Time or under Simple Setup.

I’ve done a factory reset on the phone and forced it to download new files from scratch, still no dice. I’d rather not set the time options up manually, as Polycom local/web config seems to override the TFTP config.

Any advice?

I can manually provision the phones by setting the provisioning server explicitly in the web config. This does not resolve the problem of getting the phones to take the DST config.

I guess another problem stacked on top here, is that the phones don’t seem to be picking up DHCP option 66 or 160! It’s how they were originally configured, so the configuration worked at one time.

Any ideas?

I am having the same issue. It started when I ran some of the module updates. I cannot remember what all they were, but I know the core was one of them. Afterward, my phones (Soundpoint 550) started blinking the incorrect date and time. I have tried wiping them and re provisioning them to no avail.

ntpd seems to be working correctly on the server. I have no idea where to begin to look for the fix.

Forgot to include my sip.cfg settings:

Are you on the freepbx distro? Google the command hwclock. I was able to fix this issue by syncing the hardware clock and system time. Dont remember where I found the info.

The time is correct on the PBX itself, but I’m using pool.ntp.org, not my pbx, as the NTP server, so correcting the system time on the PBX will not resolve my issue. Also, since the PBX is correctly connecting to the internet time server, that would indicate that there aren’t any network issues connecting to that internet address.

Since the time is off by one hour, I’d assume it has something to do with DST not getting configured in the phones.

I’m guessing at this point that we’re going to have to go through and manually adjust every phone to use the correct time settings, because while it seems possible to do it automatically, it’s beyond me why it’s not working. I mean, we have the same exact setup at 7 locations and just 2 of them aren’t working correctly.

So much for endpoint managers.

I finally fixed my issue. I had to go into:
Connectivity > OSS Endpoint Template Manager

From there, I entered edit mode on the template I am using for my phones and then clicked to edit “Global Settings”. I changed the NTP server settings from “pool.ntp.org” to one of the IP addresses that pool.ntp.org resolves to. After applying the changes, my phones rebooted and voila! No more blinking date/time as well as the correct date/time.

Not sure why this setting did not like the DNS name for the SNTP server, but oh well… all is good now.

Alan, DNS was my guess as well, however scrolling through the TCP/IP parameters (Polycom IP550) shows everything is set correctly.
My workstations, Router, switches all use pool.ntp.org for the SNTP and work w/o issue, all using the same DNS servers as the Asterisk box and phones.

This issue did not present itself until after a module update. I am almost certain that the OSS Endpoint manager was among the list of modules that were updated, but I am not 100% sure.

Perhaps the phones could not resolve pool.ntp.org. Are the phones configured with a DNS server? Perhaps the firewall is blocking. Do the phones have a default gateway?