Polycom Soundpoint IP 330 problem

Hi, I am new into FreePBX,

I have succesfully configured my freePBX on my RaspberryPi, but I am not able to connect my Polycom Soundpoint 330.

Unfortunately, the web access of the soundpoint was disabled when I bought the device, so I have to work it out from the phone dialpad. I have tried to factory reset it through the phone menu, I think that I have been a little to much succesful at that, because it zap everything even the previous SIP.cfg file. Not it gave me an error when booting and the cfg file had been rename with the macaddress.cfg. And the Phone doesn’t get an IP automatically from my gateway as previously.

I read on the net that I have to configure a TFTP server on raspberryPi ( Raspbx ), but I don’t know what to do to make it happen.

Can I run a TFTP server on my Windows8 and the soundpoint could grag the file there ?, If yes which file(s) ?

I sucessfully added the end point in the freepbx, so I can see soundpoint files under the tftpboot directory

I can see a

MAC_adress (xxxxxx.cfg) and a sip_3333.cfg files there

But there is no TFTP server enable. how can I install one and enable it.

I have tried the tuto, but it didn’t work


any help to make my soundpoint alive and connect to the freepbx tftp server?

Any help will be a start for me



By default (your factory reset) I believe the Polycom’s will use ftp for provisioning. You can change that in the advanced menu default password is 456.

I have been successful to provisioning the phone by using the HTTP instead of TFTP, it is now fully functional

Thanks !!!