Polycom Phones configuration


I need to configure a Polycom phone to work with my AsteriskNow system.

Does anyone has a working config? or can help on this matter?


I got it to work by downloading 2345-12365-001.bootrom.ld, bootrom.ld, 2345-12365-001.sip.ld from the Polycom website and i moved the files created by the Endpoint Manager to same tftp, well what i am sure of is that Endpoint is not downloading the firmware for 331 to the tftpboot folder, because i tried another phone type and it worked, anyways now that i got it to work like this, i would like to activate Users & Devices, how can i do that ? is that a module?

Note: let me know if you would like me to do some tests to check the firmware download issue with Endpoint!

go into logs and see what errors it’s giving.

The firmware file is right there. it’s called “sip.ld” though I don’t see the bootrom file. It should be around there somewhere too. Actually you should have all of the files listed here:


Just checked the downloader and yes they should all be in there.

I already have the firmware installed for Polycom phones 331 series and enabled the 331 phone so after installing the firmware and enabling the 332 phone series and adding a phone, the following are the files created in my tftpboot folder:

000000000000.cfg phone1.cfg
0004f2a603be.cfg contacts server.cfg
0004f2a603be_reg.cfg licenses sip.cfg
logs sip.ld
LoudRing.wav SoundPointIPLocalization
overrides SoundPointIPWelcome.wav

is it missing something? i feel that it didn’t download the firmware files though it says “remove firmware” …

The phone is also requesting the following files, but it cannot find them in the tftp directory since they were not created by endpoint…so the start up of the phone hangs after it loads the sip.ld file and the mac-address.cfg file


Those are firmware files. You need to click “install firmware”. Also I don’t provide separate sip.ld files in the firmware download. It’s all one big download. So the phone might still request that but it’s ok

It’s fine to move them. What file is it stopping at

I am having problems getting the the Polycom phone work with the centos tftp, i have configured Endpoint and it created the necessary files in /tftpboot, so i installed a tftp server on a windows machine and moved the files created by Endpoint to the windows tftp server, now i see that the phones loads sip.ld and another files and it stops…

is it correct to move the files created by endpoint to another tftp server and it should work?

Thanks for your help, i will try to make it work in that mode and if i encounter any problems i’ll ask.

Thanks. Let me know

I have a question, if i already have a DHCP server on my network, do i still need to configure a DHCP server on Asterisk? or just configuring End Point Manager will do,i am using Polycom phones.


No you don’t. A DHCP server is used to set option 66 & 150 which are related to telling phones where the tftp server is located.

If you don’t set those options in your dhcp server then you’ll have to set it on each phone, otherwise the phone will have no idea where to get it’s configuration files from.

Using End Point Manager can we enable logging from the phone itself?
or the only solution is that the extension is pushed from the server?

What do you mean by logging?

I that in the normal operation the phone will acquire the extension that was bounded to its MAC address on the Endpoint Manager Module, right?

Now if a user moved to another phone and he wants to take his extension with him, can he, by entering a username and password move that extension to another phone.

I think this is called extension mobility or hot desking.

It’s call “Device & User” mode in FreePBX and Endpoint Manager works in that mode too. It says extension on the configuration screens but it gets it’s data from the devices database


Nice module, makes life easier, thanks!