Polycom Phone will register but not make or receive calls

asterisk
bug
configuration
freepbx
Tags: #<Tag:0x00007f7027bb8cf0> #<Tag:0x00007f7027bb8a70> #<Tag:0x00007f7027bb8890> #<Tag:0x00007f7027bb86d8>

(Lachlan Wintour) #1

Hi there,
My Polycom phone will register to the server, but is unable to make or receive calls. My bria soft phone registers and can make an receive call happily, but the Polycom wont. Can someone please help me?

Please note: I am in the AEST (Australian Eastern Standard Time) timezone, so I may be a few hours to respond to any posts.


(Sergio Lobera) #2

Hi ! Are you using chan_sip or PJSIP ?


(Lachlan Wintour) #3

The phone is using port 5060. Im new to freepbx so I dont know what that is.


(Matt Brooks) #4

I’m going to say it’s probably a networking issue. Is your polycom phone local to the PBX network? Are you running a VPN on your Bria setup that may make it work?

Make sure you read over this guide to eliminate any NAT issues:
https://wiki.freepbx.org/display/FPG/NAT+Configuration+FreePBX+12


(Lachlan Wintour) #5

There is no vpn. The phone and the computer are both on the same network.


#6

dial plan on the telephone?


(Lachlan Wintour) #7

No, there is no sip trunks connected to the pbx.


(Matt Brooks) #8

But what IP is FreePBX telling the phone to connect to? The public or the private one? It’s possible that Bria maybe doing some magic out of spec to make things easier, but I’m not 100% sure. Did you verify the settings in that guide?

If FreePBX is telling the phone to connect to the public IP, then it’s possible NAT isn’t translating that correctly. OR it’s firewalled. Basically, it’s bad.


(Lachlan Wintour) #9

It is connecting to the private / internal ip of the server.


(Matt Brooks) #10

Have you verified this by looking at the SIP Packets using a tool like Wireshark or tcpdump?

I think you can also look at the Asterisk console to see the SIP packets in debug:
http://pingbin.com/2012/09/asterisk-sip-packet-debug/

Basically, your private IP should only show up in those and never your public IP.


(system) closed #11

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.