Polycom MWI

Up until now I have only used the FreePBx Distro as a trunk gateway for legacy PBX’s and have not had a box in production that has extensions connected in anger. I am now implementing a full PBX system using the distro and I have found that a Polycom 550 phone does not show messages waiting - the red light does not flash, the mail icon does not show and there is no stuttered dial tone.

By trial and error I found that if I change the mailbox option in Extensions from extn#@default to just extn# everything works normally. I am now embarking on testing with Polycom 335, Panasonic Dect IP Phones and Linksys ATA’s. I will report my findings once I have done this.

In the meantime can anyone give me some insight on why this may be happening as I have not found anything about this when Googling around?

In the MAC.cfg I put ( with success) :

<msg msg.bypassInstantMessage="1"> <mwi msg.mwi.1.subscribe="your_extension" msg.mwi.1.callBackMode="contact" msg.mwi.1.callBack="*97" msg.mwi.2.subscribe="" msg.mwi.2.callBackMode="" msg.mwi.2.callBack="" msg.mwi.3.subscribe="" msg.mwi.3.callBackMode="" msg.mwi.3.callBack="" msg.mwi.4.subscribe="" msg.mwi.4.callBackMode="disabled" msg.mwi.4.callBack="" msg.mwi.5.subscribe="" msg.mwi.5.callBackMode="disabled" msg.mwi.5.callBack="" msg.mwi.6.subscribe="" msg.mwi.6.callBackMode="disabled" msg.mwi.6.callBack=""/> </msg>


That is exactly the setup I have in my Polycoms, it has always worked with earlier versions of FreePBX/asterisk, it only seems to have stopped working with FreePBX 2.9/asterisk 1.8.

I have tried Polycom 550 and Polycom 335, both do not work with the extension [email protected], take it out and only leave the extension number and its fine.

I have tried Xlite, Linksys ATA and Panasonic KXTGP500 and they all work with the standard config. Weird!

I will have another look at the Polycom configs to see if there is anything else under Messages that might affect it.

Copy and paste the code I provided ( changing the ext) and see what happens. I found that exact format to work and nothing short of it seemed to do.