Polycom IP331 not ringing when called

I have several of these phones and they all seem to be getting their config file from the server. When i pickup the handset to make a call there is no dial tone. I am able to call other phones but when i do i dont hear the other end ringing in my handset. Also if i call one of these phones the phone does not ring but the display shows as an incoming call.

Did you find out anything? I have the same problem with a Polycom IP331.
I’m running asteriskNOW distro with all updates as of 4-10-13.

Note, this is something new - since I have other IP331s on my system which are not doing this.
Can place and receive calls no problem - just don’t get dial tone or hear ring in the receiver when placing calls. Also don’t hear any ring for incoming calls - but the display shows the call - and I can pick up the call and talk/hear no problem.

The reason for my issue is that I enabled the right model phone I just didn’t install the firmware. Once I did that they worked perfectly.

OH You’re RIGHT - I did this on my old server - but when I replaced my asterisk server, I FORGOT to click that (!) Didn’t notice until I bought some new handsets - since my [onhand] phones worked… what a dumb mistake