Polycom and EPM, Error, application is not present!

I am currently configuring a new FreePbx version 13 system. I am able to connect using a softphone and everything appears to be working fine. I have used End Point Manager to create a template for a Polycom 550. I am using FTP to connect and can see the phone is connecting and updating the firmware during the initial boot. I get the following sequences on the phone screen.

Updating Boot Rom
Formatting Files System (Reboot)
Wait for network to initialize
Updating polycom/sip.ld
…polycom/2345-12500-001.sip.ld please wait (this number changes per bios version tried.)
Error, application is not present!

I get this error consistently, no matter which firmware version I select in Firmware management under EPM. I thought EPM would confirm that the compatible files such as the sip.ld would be installed based on the firmware selected. I have also tried having another firmware version listed in slot 2 under firmware management. I am able to revert the phone to it’s previous working state by downgrading the sip.ld when I point it to our current Trixbox phone system but can’t seem to get it connected to Free Pbx.

I am not sure where I am making my error and any help is greatly appreciated.

Thank you, in advance for your suggestions.

HI Ottis

Application not present will show up after you format the phone and it can’t download the firmware. Make sure in the log of your tftp or ftp you do not have any error and the you see your phone download the firmware ( it will do it about 3 times). the 2345-12500-001 is for if i’m not mistaken for an ip550. that could an incompatible firmware or an ftp permission issue.


Hello Yves,

I appreciate the suggestions but it appears the firmware is being downloaded. I have attempted both FTP and TFTP connections with the phone and I see it update the bios. I am able to use EPM and connect an Aatra phone with no issues. I tested using a brand new Polycom 650 this morning using TFTP and it updated the phone’s bios as expected but unfortunately I got the same issue with application not present. I know from experience with Trixbox that if the phone sip.ld isn’t compatible with the firmware you will get this message on the phones. It is my understanding that EPM should handle the sip.ld and firmware compatibility issue but I might be mistaken. I have considered trying to use a combination of Firmware and sip file that I know works on Trixbox but I would rather make sure I am using EPM correctly before I start down that road.

I have looked through the asterisk logs in the user interface and didn’t seem to find any information about the devices attempting to connect. I have also ssh’d to the server and looked around in the /tftpboot folder and it’s sub folders such as /tftpboot/polycom/1. I see the config files, bootrom.ld, and the corresponding sip.ld files but I can’t seem to find a log that will indicate a connection status error. Please forgive my ignorance on the subject but would you be able to direct me where you would expect to find such a log. My previous searches would lead me to believe I should see them in the /tftpboot directory.

The problem is probably that the firmware loader on the phone is too old and won’t accept the new firmware applications on the TFTP server. You probably need an intermediate firmware update to get you updated to the latest firmware completely. There used to be an option in FPBX 12 EPM to do this. I think on the firmware management page, when you select Polycom, at the bottom of the page there is a checkbox that says “Use Upgrader Bootrom for looping phones”. Have you checked to see if you have this enabled?

Thank you for your suggestion, I have tried this connection with this option selected and unselected with the same results. I have tried various versions of the Availble Firmwares in EPM always getting the same results. "Application Not Present. When I select a newer version of Firmware I do see the phone behave as if it is receiving the updated files but then still reports Application is not Present. I am connecting to the server using FTP currently but I have tested with TFTP also just to confirm that I don’t get anything different.

I had the same problem so I downloaded the firmware from the Polycom download matrix and upgraded manually. If you do this download the combined load which supports older BootRoms. Get a free tftp server and configure its base to the extracted SIP load and point the phone to your computer. If you’re on a laptop or workstation you may have to drop your firewall, or open port 69. The phone will upgrade automatically and you should be able to point it back to the pbx after it’s done. It may have to reboot a couple of times. Read the instructions which provide alternate upgrade solutions for old boot loaders where they supply a link to the upgraded BootROM.

I have done some further testing and I can get the phone to register and come online by manually editing the mac address.cfg to point to the sip.ld file. ( APP_FILE_PATH=“polycom/sip.ld”) This file by default points to polycom/sip.ld which is not a valid directory. There is however a /tftpboot/polycom/1 folder that has a sip_318.ld file. I made a copy of this file named sip.ld and pointed the config file to this location and the phone finishes updating and connects. The NTP service however doesn’t seem to connect correctly and I am sure there would be other issues if I proceeded to manually edit these files which specifically state DO NOT HAND MODIFY THIS FILE. So, I am obviously making connection to the server fine and my understanding is that End Point Manager should be handling these configs for me automatically based on my templates I configure in the user interface. Has anyone else had similar issues with Polycom phones and end point manager right out of the box?