Pointers on fax

Have “searched” forum and did not find anythig specific so posting for any pointers to where I can look, or if anyone has suggestions on solutions - most appreciated.

Inbound faxing to us - either to an extension or to an inbound route/DID seems to work most of the time, However, some inbound faxes never work.

For extensions we use:

Fax Extension: "System"
Fax Detection Type: "Zaptel"
Pause after answer: “6” seconds
and the email is specific to the user…

For Inbound Routes we use:

Fax Extension: "freePBX Default"
Fax Detection Type: “Zaptel” (we’ve also tried “none”)
Pause after answer: “6” seconds
and the email is specific to a user…

For customers that send to use that fails, one of the most common errors they see is: “POOR LINE CONDITION”. That is, they are not able to send a fax as it never “connects”.

We’re running version 2.2.3 of freePBX

TIA, Bill

You have not provided the important details.

The type of trunk or line the faxes are coming in on? Sip, IAX, Zap/Dadhi, etc?

For a DID that is dedicated to a fax don’t have it do detection just forward it directly to the fax service. To do this using FreePBX 2.5 you create a Misc service that is the fax service. then create a DID that uses the fax detect and has the settings you want for e-mail notification, etc. and set the detection to 1 second (need to have it not be zero) then set the destination to the Misc destination of the fax service you created. It will then just go into the responding mode without attempting to dtect it first and this helps when the detection tones are just slightly out of sync.

If you are using anything except a hardline (T1, PRI, ISDN, ZAP/Dadhi, E1) you are lucky it works at all. Sip or IAX can work some times if you DO NOT use compression, but put compression on and you drop from 60% to 3%. Compression alters the actual audio frequencies you hear to compress it, and for a fax the signal has to match almost exactly for a fax to work. 99.9998% of the humans in the world can’t tell the difference between a given frequency and one that is off just 3 hertz, but your fax machine can.

I can’t remember the detection frequences off the top of my head but there is about a 5% tolerance on it and if the sending side is on the low side of that and the receiving side is on the high side then it’s possible that that span is more then 5% between the two sides and it will fail. Sometimes you get lucky by calling the fax service directly as it just sends back the acknowledge tone back to the otherside and the calling side hears it and then it’s on to the next detection tone and that gets heard when sent back. sometimes it is not.

Cheap fax machines are the worst.

I’d like to enable fax service on an inbound PSTN line.
The PSTN line is not dedicated to fax reception but is normally used to place and receive calls.
For this purpose I’ve setted in:

General Setting:

and on inbound route (i.e. on a Zaptel Channel):

Fax extension: FreePBX Default
Fax Email:
Fax Detection Type: NVFax or Zaptel
Pause After Answer: 3 (or 6, or any other value)

By this way I can receive fax that are e-mailed correctly but if the inbound calling is not a fax the extensions (added to the ring group setted as “destination” in inbound route) continue to ring even if the caller (another phone and not a fax) has hunged up.
The phone continue to ring until a person (uman) pick the handset and, obviously, hear nothing.
Is there any way to resolve the issue ?
In other words can I use the same PSTN line to receive and place call on a PSTN line and at the same time use the PSTN number as an automatic fax receiver?
Thanks in advance.
Ing. Cosimo MERCURO
Mercuro for Business

Thanks fskrotzki for the reply. Appears we’re in the “you are lucky it works at all” category as we use a PRI. Seems we’re about 50-50 - we’ll just keep our POTS and stand-alone fax machines. Thanks again for the tips!

POTS and PRI will work as long as you don’t do a conversion of the signal to say SIP or IAX. We use a PRI and POTS line at the office. The PRI hit’s good about 95% of the time, the POTS is closer to 80% of the time. on a POTS line watch your rx and tx gain settings because if they are to high and you get a call that has a strong signal it will actually have to much gain and clip the tone such that nothing will be heard and cause issue also. You’ll also want to be sure that the setting to disable echo detection are set correctly on fax signaling as that will also alter the tone.


While we are talking about faxing in this thread your issue is actually considered a hijacking of the thread as your issue has nothing to do with the current issue at hand.

Please repost it as a new question. At the same time you’ll need to provide a lot more info as you’ve not given us things we need to help. Please read http://freepbx.org/forum/freepbx/installation/so-you-have-a-problem-and-want-help for the things we need to help you.