PM2 module update error


The latest PM2 module update causes another error.

When updating to pm2, I got a red box and warning ‘Unable to locate the FreePBX BMO class Pm2A required module’. I ran ‘fwconsole ma install pm2’ using SSH login to machine (it did not work from FreePBX cli. After running I did the usual chown command and all was fine…

Are these updates tested before release (did the same thing on my 2 servers so not a one off)?


Yes they are.

Since you didn’t post the full error anything would be speculation as to what happened.


Sorry for my cryptic and abrubt message. See attached the error (screen grab) that came on both machines on update (auto update as I have the purchased admin module).

Along with this - I had an error some 3 months back too, a module which had an update. this update had an error, it was then updated again… (I belive this was XMPP).These two errors come after over a year of updates with no problems, hence my (uncalled for) catty post…



I had the same problem
I found this thread and it is solved…


Got sorted. Its all OK now. Cheers for the advice…