Please help with remote Cisco SPA phone with EPM

REMOTE Polycoms, softphones (i.e. Groundwire) have no issues placing/receiving calls remotely. The server is PBXAct UC 25 which is behind FQDN domain. All ports routed correctly as all phones have no issues calling/receiving calls EXCEPT FOR CISCOs. These CISCO models are driving me crazy.
SIP driver is ONLY PJSIP globally for the whole system.
Both locations have identical router with all necessary SIP settings set (e.g. SIP ALG is off etc.)
Again the issue isn’t ports as other remote phones are working fine except for CISCO’s.

The CISCO SPA508G provisions SUCCESSFULLY with EPM remotely via TFTP (all the provisioning settings are being downloaded and line shows as registered), HOWEVER no calls can be received at the remote CISCO phones SPA508G (doesn’t ring at all, goes to VM), and when you try to place a call, no matter which number or extension or even just to voicemail - it stays silent for ~15secs then gives busy tone. Never shows call as connected. Again, it registers and provisions successfully but no calls capability.
Kindly advise what to try to change. thank you

Check your codecs are correctly ordered and also supported by your Cisco

Thanks for your super fast reply, greatly appreciated.
In the Cisco I set the following:
Enabled codecs: G711u, G711a
Preferred codec: G711u / Secondary preferred codec: G77a

NOW I can CALL OUT without issue. HOWEVER incoming calls don’t ring the phone. The person who calls the extension hears ringback tone BUT the phone doesn’t ring.

If you are in NANPland just use g711u, to see incoming calls start with sngrep (it operates on the kernel level before any filters.)

(Are you in North America ?)

1 Like

Just enabled ONLY G711U and everything’s working fine now.

I am sure someone over the years will come across this thread and apply this simple solution and it will save them hours of their time. I know your posts across the forums have helped me endless times.

(Yes, North America)

1 Like

For the record (this would be something I was also searching for online and couldn’t find solution to) -
the same fix applies to all CISCO SPA-series phones as well as MPP/3PCC phones.
e.g. my Cisco 8861, 8851, and 8841-series 3PCC phones also had the same issues with calls not ringing/dialling as above, so I set the following settings and they work fine:

  • Preferred codec: G711U
  • Use only preferred codec: YES

(Cisco 88xx 3PCC phones work perfectly fine on the SPA508G template in EPM, you can edit their basefiles to anything you want! Cisco 88xx 3PCC phones are based on the SPA-series templates with just a few extra things added.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.