Please help me configure TE133 Single-Span T1/E1 Card use FreePBX


(Truong Tran) #1

Hi guys,
I have tried the configuration a lot for TE133 Single-Span cards on FreePBX, but it still doesn’t work properly, please help me configure it.

I have setup a ISDN card and use FreePBX 15.0.16.49.

I use 2 TE133 cards on 2 FreePBX, temporarily called FreePBX A and FreeBPX B.

The call from FreePBX A comes in FreePBX B, the phone rang, and when I answered, the call only lasted for 31 seconds, then it automatically hangup. I have noticed its giving > Span 1: Channel 0/1 got hangup request, cause 16
Below is the log part of FreePbx B:
–PJSIP/100-00000001 answered DAHDI/i1/101-2

– Channel PJSIP/100-00000001 joined ‘simple_bridge’ basic-bridge <64fc141e-1016-4fd7-9111-46f619672291>
– Channel DAHDI/i1/101-2 joined ‘simple_bridge’ basic-bridge <64fc141e-1016-4fd7-9111-46f619672291>
– Span 1: Channel 0/1 got hangup request, cause 16
– Channel DAHDI/i1/101-2 left ‘simple_bridge’ basic-bridge <64fc141e-1016-4fd7-9111-46f619672291>
== Spawn extension (macro-dial-one, s, 56) exited non-zero on ‘DAHDI/i1/101-2’ in macro ‘dial-one’
== Spawn extension (macro-exten-vm, s, 26) exited non-zero on ‘DAHDI/i1/101-2’ in macro ‘exten-vm’
== Spawn extension (ext-local, 100, 3) exited non-zero on ‘DAHDI/i1/101-2’
– Executing [h@ext-local:1] Macro(“DAHDI/i1/101-2”, “hangupcall,”) in new stack
– Executing [s@macro-hangupcall:1] GotoIf(“DAHDI/i1/101-2”, “1?theend”) in new stack
– Channel PJSIP/100-00000001 left ‘simple_bridge’ basic-bridge <64fc141e-1016-4fd7-9111-46f619672291>
– Goto (macro-hangupcall,s,3)
– Executing [s@macro-hangupcall:3] ExecIf(“DAHDI/i1/101-2”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [s@macro-hangupcall:4] NoOp(“DAHDI/i1/101-2”, "PJSIP/100-00000001 montior file= ") in new stack
– Executing [s@macro-hangupcall:5] GotoIf(“DAHDI/i1/101-2”, “1?skipagi”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [s@macro-hangupcall:7] Hangup(“DAHDI/i1/101-2”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 7) exited non-zero on ‘DAHDI/i1/101-2’ in macro ‘hangupcall’
== Spawn extension (ext-local, h, 1) exited non-zero on ‘DAHDI/i1/101-2’
– Hungup ‘DAHDI/i1/101-2’

On both FreePBX A and B, I created and used:

  1. Extension: PJSIP
  2. Inbound
  3. Outbound
  4. DAHDi Trunk!

This is configuration information for the TE133 card on FreePBX B. The configuration on FreePBX A is the same as on FreePBX B. They differ only from Signaling

Note: Signaling on FreePBX A is PRI - CPE , and Signaling on FreePBX B is PRI - NET. . If I use the same Signaling, the call won’t work between FreePBX A and FreePBX B, I don’t know why either

Please help me to see where I am getting the wrong configuration.

Thank you so much.


(P Ramarajan) #2

“the call only lasted for 31 seconds, then it automatically hangup.”

This looks like an RTP timeout issue, so check your sip settings and configure it properly.
Also, check you have added the local networks in the sip settings or not? if not try to add then test the call.


(Truong Tran) #3

I tried increasing the RTP timeout to 60s, everything didn’t change, so I thought it wasn’t due to RTP timeout.
I already added the local networks in the sip settings.
I have seen cause No. 16 - normal call clearing.
It looks like my digital card configuration is incorrect


(Truong Tran) #4

I still haven’t solved this problem.
Hope you can give me more suggestions.


(Eko VoIP) #5

Hi, did you try to go on chan_dahdi.conf and add some new lines of code that may help on removing that error which is ending automatically the call after 31 seconds. Some parameters which may help and you can test adding-removing one by one if they are not already there are:
callprogress=no or callprogress=yes if 1st one doesn’t help
echocancel = yes
echocancelwhenbridged = yes
relaxdtmf = yes


(Truong Tran) #6

I tried to test adding-removing one by one and all as your suggestion
Try replacing the value of the parameters with yes or no
But the results have not changed

Here are the parameters in my chan_dahdi.conf file

[channels]
language=en
busydetect=yes
busycount=10
usecallerid=yes
callwaiting=yes
usecallingpres=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
callprogress=yes
echocancel=yes
echocancelwhenbridged=yes
echotraining=no
relaxdtmf=yes
immediate=no
faxdetect=no
rxgain=0.0
txgain=0.0
alawoverride=0
alawoverride_checkbox=0
boostringer=0
boostringer_checkbox=0
echocan_nlp_max_supp=
echocan_nlp_threshold=
echocan_nlp_type=0
fastringer=0
fastringer_checkbox=0
fxs_honor_mode=0
fxs_honor_mode_checkbox=0
lowpower=0
lowpower_checkbox=0
module_name=wctdm24xxp
mwi=none
mwi_checkbox=0
neon_offlimit=
neon_voltage=
opermode=USA
opermode_checkbox=0
ringdetect=0
ringdetect_checkbox=0

In my chan_dahdi_groups.conf file

signalling=pri_cpe
switchtype=national
pridialplan=unknown
prilocaldialplan=unknown
group=0
context=from-pstn
channel=>1-15,17-31


(Truong Tran) #7

In my /etc/dahdi/system.conf file

span=1,0,0,CCS,HDB3,CRC4
bchan=1-15,17-31
dchan=16
loadzone=us
defaultzone=us
echocanceller=hwec,1-15,17-31

When I run dahdi_scan command:

active=yes
alarms=OK
description=Wildcard TE131/TE133 Card 0
name=WCT13x/0
manufacturer=Digium
devicetype=Wildcard TE131/TE133 (VPMOCT032)
location=PCI Bus 01 Slot 01
basechan=1
totchans=31
irq=0
type=digital-E1
syncsrc=0
lbo=0 db (CSU)/0-133 feet (DSX-1)
coding_opts=AMI,HDB3
framing_opts=CCS,CRC4
coding=HDB3
framing=CCS/CRC4


(Truong Tran) #8

Thank you very much.
My problem is solved in post of @pramarajan
Yesterday I added the local network and I only restarted Asterisk.
Now I reboot my Server => My problem is solved

Best Regards,
TruongTV


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.