Pjsip video call

I converted my extensions from using chan_sip to chan_pjsip and now video calls between handsets don’t work.

Simple, question: should it work?

Harder question: if it should, how do I diagnose fixing it?

I’d offer a load more info here but I’m not sure what would be relevant, after all I’m not sure it’s supposed to work at all.


Me again…

In case you couldn’t tell, I have been playing with SIP video quite a lot too.

The issue that I found is that once you switch to PJSIP, there are no longer any settings in the Asterisk SIP Settings GUI to manipulate codecs.

I went into each extension and in the Allowed Codecs list, added h264.

That got video going. I don’t know where to set this by default in the FreePBX web interface.

Ha, well I hope you didnt suffer as much as I’ve been!

Your hint did indeed work, so I got a video call working over pjsip. One of the trunks works and I’ve not got to doing the other yet. The idea is to put everything into pjsip and turn off the old chan_sip driver.

There’s a catch to your suggestion though, unless I’m going crazy. Putting the h264 there seems to override the fix you gave me earlier about adding to the dialplan to prevent video on calls where video is not appropriate, like PSTN.

This honestly seems to be an issue with FreePBX, as there is nowhere to permit h264 on a general level, in the way there is with chan_sip.

I’ll raise an issue for it and see what they say.

May I ask what phones you have been using Bill? I’m experimenting with a Cisco 9971 and 9951. They are a nightmare to configure but I think I finally solved most issues today. The big one is that missed calls show in a big green box on the phone and never disappear, reboot the phone to get rid of them! Fixed now, and boy was I relieved!

It shouldn’t do that. If you specify the codec Allowed Codecs list in the extension, it is adding this to the SIP (PJSIP) config. The workaround I gave you earlier happens at a dialplan level and so should still work whether you are using chan_sip or PJSIP as your driver. I admit I have not tried it though. The workaround is in production in my environment with Asterisk 11 (chan_sip).

I am using a mix of Grandstream and InFocus video phones.

I’ll recheck everything next week, though I’m glad to hear that the order of execution should mean that it’ll work. I must have had some extra code somewhere.
Thanks for your feedback.

Confirmed, that fix to disallow video for certain calls only works with chan_sip.

I’ll raise another issue ticket.