PJSIP trunk with sipgate.de Basic account configuration

trunk
configuration
pjsip
Tags: #<Tag:0x00007f7033d35ea0> #<Tag:0x00007f7033d35ae0> #<Tag:0x00007f7033d35450>

(Rh) #1

Hello everybody,
took me a while today to get FreePBX connected to sipgate.de basic, so I thought it might share my (finally) working configuration. I am using SNG7-2020-02 with todays updates to all modules and I’ll just note what I changed and omit (almost) all the unchanged default values.

PJSIP trunk settings for a Sipgate Basic account in Germany:

Tab General:
TrunkName: SipgatePJSIP (or whatever you want to call it)
Outbound caller ID: <YourPublicPhoneNr> e.g. “<004932112345678>”
Tab pjsip Settings - General
Username: sipgate acount ID, e.g. “1234567a0”
Secret: sipgate account PW
SIP Server: sipgate.de
SIP Server Port: 5060
Context: from-pstn (default)
Tab pjsip Settings - Advanced
Expiration: 600
From User: sipgate acount ID, e.g. “1234567a0” (if you get this wrong, you’ll hear sth like “all lines are busy, pls try again later” on outgoing calls)

Hope this can be helpful for someone. Good luck :slight_smile:


(James) #2

I have tried these settings with Sipgate Basic UK, only changing the sip server to sipgate.co.uk. So far so good, I’ll update again in a few days time.


(James) #3

Here’s an update (although its a little bit later than planned):

For DTMF to work i had to change the setting from auto to RFC4733. To get routing based on the incoming number (DID) to work, I had to set the sipdate username in the contact user box. Hope that helps anyone out in the future.