PJSIP Trunk for FXO Behind Nat


(Steven Sedory) #1

Hi All,

We recently converted a server from the chan_sip driver to only pjsip.

Everything is working, but we’re having one way audio issues with an FXO, an Obi 110.

We have this device setup via a Trunk entry. Here’s what we had on chan_sip:

username=8880
type=friend
transport=tcp
secret=somepassword
qualifyfreq=25
qualify=yes
nat=yes
host=dynamic
dtmfmode=auto
context=from-pstn
canreinvite=no

Note the nat and dynamic parts.

I cannot figure out how to replicate this on the pjsip trunk, and therefore we’re having one way audio issues.

I read on this wiki that I need to set the following settings to replicate chan_sip’s “nat=yes”, but I can’t find them in the FreePBX UI under Trunks, only under Extensions, and this device needs to be a Trunk.

https://wiki.asterisk.org/wiki/display/AST/Migrating+from+chan_sip+to+res_pjsip

rtp_symmetric=yes
force_rport=yes
rewrite_contact=yes

Anyone know how I can have a NAT’d dynamic host on pjsip?


(Steven Sedory) #2

Anybody?


(Tom Ray) #3

You mean these settings in the Advanced tab under PJSIP settings in the trunk? Which, BTW, are set to “yes” as their default.

2019-10-12%2012_02_58-Window

You need to describe this issue a bit better. Which side is getting the one-way audio? Who can’t hear who? Where is this FXO device compared to the PBX? Etc. etc. etc…


(Steven Sedory) #4

Thank you.

We do not have those setting under the advance tab. Here’s what we have:


We’re on FreePBX 13.0.197 and Asterisk 13.23.1

Perhaps we just need to upgrade?


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.