Pjsip prack

Hi All,

Since we migrated our trunks towards PJSIP, we notice that FPBX is generating PRACK messages towards our ITSP.
2 questions:

  • Is there any way to disable that behavior? (in the trunk configuration?)
  • Is this really needed? :slight_smile:

Thanks for your help!

Usually, PRACK is a good thing. Otherwise, a single lost packet could cause the caller to not hear ringback tone or an early media announcement. What trouble is it causing?

If the provider doesn’t want PRACK, they shouldn’t request it by claiming 100rel support.

There is a 100rel option, but I’m not entirely sure which direction(s) it controls, and don’t know if there is GUI support. In any case, I can’t think why you would want to disable it.

Thanks for your replies @Stewart1 & @david55.

Some outbound calls are being cut by our ITSP (by malformed PRACK messages), and their first thought would be to disable them.

If I understand correctly, these were not present on our CHAN_SIP trunks… so I would assume we don’t need them now either :).

I’m pretty sure setting 100rel=no will disable it (but may have to be done in a customisation file). However, I’d be very surprised if something that caused it to be malformed had not been found by others, unless it is the result of misconfiguration, or a router is modifying it.

Thanks a lot @david55 ! As a workaround I added 100rel=no to the pjsip.endpoint_custom_post.conf file and PRACK messages are not present anymore.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.