PJSIP incorrect password -Updated

When switching an extension to pjsip, the extension is unable to connect.
Asterisk says it is using an incorrect password. When switching back to chan_sip it works fine.

[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:1] NoOp(“SIP/pbx.enterdomainhere.com-00000004”, “Received incoming SIP connection from unknown peer to 88”) in new stack
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:2] Set(“SIP/pbx.enterdomainhere.com-00000004”, “DID=88”) in new stack
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:3] Goto(“SIP/pbx.enterdomainhere.com-00000004”, “s,1”) in new stack
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Goto (from-sip-external,s,1)
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:1] GotoIf(“SIP/pbx.enterdomainhere.com-00000004”, “0?checklang:noanonymous”) in new stack
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Goto (from-sip-external,s,5)
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:5] Set(“SIP/pbx.enterdomainhere.com-00000004”, “TIMEOUT(absolute)=15”) in new stack
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] func_timeout.c: Channel will hangup at 2014-11-04 14:26:09.842 PST.
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:6] Log(“SIP/pbx.enterdomainhere.com-00000004”, “WARNING,“Rejecting unknown SIP connection from myhomeip””) in new stack
[2014-11-04 14:25:54] WARNING[2923][C-0000000f] Ext. s: “Rejecting unknown SIP connection from myhomeip”
[2014-11-04 14:25:54] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:7] Answer(“SIP/pbx.enterdomainhere.com-00000004”, “”) in new stack
[2014-11-04 14:25:55] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:8] Wait(“SIP/pbx.enterdomainhere.com-00000004”, “2”) in new stack
[2014-11-04 14:25:57] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:9] Playback(“SIP/pbx.enterdomainhere.com-00000004”, “ss-noservice”) in new stack
[2014-11-04 14:25:57] VERBOSE[2923][C-0000000f] file.c: <SIP/pbx.enterdomainhere.com-00000004> Playing ‘ss-noservice.gsm’ (language ‘en’)
[2014-11-04 14:25:57] WARNING[2923][C-0000000f] app_playback.c: Playback failed on SIP/pbx.enterdomainhere.com-00000004 for ss-noservice
[2014-11-04 14:25:57] VERBOSE[2923][C-0000000f] pbx.c: Executing [[email protected]:1] Hangup(“SIP/pbx.enterdomainhere.com-00000004”, “”) in new stack
[2014-11-04 14:25:57] VERBOSE[2923][C-0000000f] pbx.c: Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/pbx.enterdomainhere.com-00000004’

Also when attempting to add a new extension, I have the same error.

Edit: just noticed when I have both chan_sip and pjsip enabled there is an entry in the log from chan_sip: Wrong password.
When I switch to pjsip only there is no such message.

My phone is unable to register with pjsip enabled.

Turns out pjsip was not listing on my interface and it was loosing for port 5061.
Had no idea that the default port for pjsip was 5061

It shows you this on the extensions page in a big blue box.

No it did not,
The problem is that the pjsip transports were not enabled. No tcp udp or ws.
None were enabled so I had to bind them to the interface. After that it did.