PJSIP Follow Me No Audio

pjsip
siptrunk
Tags: #<Tag:0x00007f4f4711c770> #<Tag:0x00007f4f4711c4f0>

#1

Hello Everyone,

When performing a follow me call from an external number the audio isn’t working on the follow me external cell phone.

The audio does work if I enable “detect faxes” on the inbound DID.
The audio does work if I enable “confirm calls” on the extension.

I added progressinband=yes however I don’t believe that applies to PJSIP?

Is it possible to get this working on PJSIP without “detect faxes” & “confirm calls”?

Thanks


#2

Anyone ?


(Dave Burgess) #3

Did you submit a ticket on this so the pros can have a reason to research it?

PJ-SIP is the way of the future, but there are still enough bugs in it that it isn’t a universal “way of the present”. You might consider switching the extensions in question back to Chan-SIP and see if that does the trick for you.

Detect Faxes shouldn’t hurt you. Until it can be confirmed to work one way or the other, you’ve discovered a workable way forward.


(David) #4

Ill add a me too to this. Did you get this resolved?


(Dave Burgess) #5

One possible work-around Is right there. There may be others that are more recent than over a year ago, but those two do seem to still help.


#6

I opened ports 10000 to 20000 on my router and this fixed .


(Lorne Gaetz) #7

This is one of the cases where forwarding the RTP port range is often required, as I’ve described in detail here:


#8

I’ve got all ports open with nat 1:1 forwarding from the sip providers IP’s only. However I still haven’t got this working without using fax detection.


#9

I’m running a Meraki MX64 firewall. I confirmed with my SIP trunk provider that all SIP and RTP traffic come from the same IP’s. So I must be missing something on my freepbx setup.


(Steven Sedory) #10

Get this working? Same problem.


(Steven Sedory) #11

So found a work around. I remember having this issue with chan_sip too at one point, but don’t remember how I fixed it permanently.

If you simply have an announcement play on your follow me, or anywhere on the inbound route, you’ll get audio once the follow me call picks up.

Correction: It will work if you dial a DID (meaning it goes out to your SIP provider first, then comes back in via an inbound route). It still is silent when I dial an internal extension directly.


(Promasu) #12

Hi there,

are there any updates on that from your side with getting this working. Currently we are facing the same issues with follow me using pjsip only transmitting audio when the call comes from internal. When calling from external this does not work.

Any ideas how we can fix this?

Kind regards,
Adrian


(Jonathan P) #13

Are you running latest version of freepbx? Did you add the internal subnet to local firewall and advanced sip settings?


(Promasu) #14

Yes FreePBX is up to date and the internal network is added. Connection to the sip trunk is via a dedicated direct link so there shouldn’t be any problem with the firewall


(Jonathan P) #15

What is the port range from sip trunk carrier? 10000 to 20000 ? Check Freepbx advanced sip settings to ensure port range is the same? Are you using port forwarding on router?


(Promasu) #16

Like I said we have a direct connection to the sip server of our carrier, thus they are both in the same network. No router no nothing.
Actually don’t know why these configurations matter as everything is working properly when phoning in a normal manner and not using FMFM.