PJSIP - Dropping inbound calls only

Hi there.
I have just recently started using a provider that only offers PJSIP trunks.
I have set up a test PBX with EPM and a couple of Yealink T42S handsets.
PBX is physical box with single Ethernet interface.
Have set up VLAN on the interface and phones are running on that VLAN.
Inbound route points to ring group with these handsets as members.
Outbound route is configured.
Handsets are provisioned as PJSIP extensions.
Handset to handset calls are ok.
Outbound calls are ok.
Inbound calls to announcement with 2 minute test message is ok and call stays up the whole time.
Inbound calls to handsets hang up after 31 seconds.

Now, normally this is attributed to router.
System is behind a Cisco 887VA Modem / Router.
UDP port 5060 is forwarded to PBX
SIP ALG is turned off (no ip nat service sip udp port 5060)

The funny thing is that for the first day it all worked fine … inbound could chat as long I liked and same with outbound.
Nothing has changed on the system.

All modules are up to date and system is also up to date as below.
Current PBX Version:
Current System Version:12.7.5-1805-3.sng7

Seems like you don’t forward ports 10000-20000 to the PBX.
These ports are used for RTP/Media.

Try forwarding them.

I was hoping I wouldn’t have to do that as that is a lot of lines in the cisco to write …
I will decrease the range to just 10000 to 10040 to handle 5 concurrent calls and see if that works …
My previous one on same setup had no rtp forwarding and worked fine.
Also, the media plays fine when calling into an announcement with long message (2 minutes plus) …
I’ll let you know how it goes.

Why would some connections need rtp forwarded and others not when same router ???

OK… so i changed RTP ports to just 10000 to 10040 as the trunk is only 5 channels.
Did a test call this morning with no problems.
I thought that may have been the case but previously I did not have to forward the RTP ports and thought it strange that messages were playing fine for more than 30 seconds but as soon as extension picked up then the 30 second timer would start.

Thanks for your help :slight_smile:

I had a similar issue with calls timing out after 31000ms. Issue was then fixed when we bound to the right outgoing IP.

If it happens again check your network routes and make sure everything is as you expect it to be.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.