PJSIP bug or misconfig after upgrade? Registrar suddenly change with Outbound_proxy set


(Serinfbco) #1

We recently upgrade to FreePBX version 6.12.65-24. Since that, suddenly many registrations failed whitout reason. We got the error log message:
res_pjsip/pjsip_options.c:315 qualify_contact: Unable to apply outbound proxy on request to qualify contact sip:324@172.16.X.X:5060

The problem comes from the AstDB whrere the registrar entries suddenly change to this:
/registrar/contact/324;@sip:324@172.16.X.X:5060:{“outbound_proxy”:“asterisk”,“uri”:“sip:324@X.X.X.X:5060”,“user_agent”:"PolycomSoundPointIP-SPIP_550-

Notice the “asterisk” value for outbound_proxy setting. Where does it come from? We don’t use NAT and all endpoints are on local private network. Something happen maybe about network discovery and Asterisk believe these endpoints are behind NAT and use proxy. But we don’t…

What can we do to disabled this? I have noticed in pjsip.endpoint.conf that overwrite_contact is set to “yes”, should it be set to “no” since we don’t use NAT?

Here some configs maybe we set wrong:




SIP 500 - Internal Server Error
(Andrew Nagy) #2

You can set that in the GUI so see if changing it works.


(Serinfbco) #3

Thanks for the suggestion. I have change the “NAT setting” in Chan SIP page from “never” to “no” because it is easier. The problem didn’t came back since that but I don’t like to cross my fingers that was just that… I would like to understand where comes from the value “asterisk” in the outbound_proxy setting since the default value is “” (blank). I don’t like the feeling that something “magic” happen in our voice system!