PinSet password, followed by #

For some reason I have a select few numbers that my users can not call out on as it’s asking for the password followed by the # key even though I don’t have any pinsets set to any of my outbound routes. To make sure of this, I also don’t have any pinsets made in the Settings>PinSets. Everything I’ve found online only talks about outbound routes, but there has to be another place to put some kind of password requirement and I just can’t find it.

Welcome to the forum. Try sharing a call trace via pastebin, that will tell us if the PIN challenge is on the PBX and where.

Thank you Lorne, I’m still very new at this. I don’t know if you’re just looking for the link or if I was supposed to paste it to the site somehow.

Your system has custom dialplan which you can see starting at line 150 in your call trace. It is this custom predial hook which is forcing the PIN authentication.

Unrelated to your current issue, but know that this dialplan is also also using the deprecated MYSQL Asterisk application, so it will have to be rewritten or removed before you can upgrade Asterisk beyond ver. 18.

Awesome thanks for your help! I didn’t even know there was pinsets in MYSQL. The former manager just had us updating a list of blocked numbers on there with no other explanation and nothing ever changed in freepbx. It’s been a nightmare of learning in a very short time just to make things work correctly with trunks and setting up actual outbound routes. I’m still finding buried things like this but it’s getting better. I have one other call that I can’t find and it’s not in this solution of the ‘blacklist’ on MYSQL. Would you mind looking at it?

This call proceeds similarly to the first. When it gets to the custom dialplan in the predial hook, it passes the blacklist check, but there is an additional check around line 167 which is blocking the outbound call due to time zone violation. Presumably there is a check preventing the call if it’s after hours at the destination.

Where do I find the custom dialplans? Is that in MYSQL or the FreePBX gui? Reason I ask is the number isn’t a time zone violation and it doesn’t matter what time of day we call it, it just gets blocked.

They are in a text file: /etc/aterisk/extension_custom.conf. See the following for general background and a module that gives GUI editing, although it will only be a text editor.

Thanks to both of you, you’ve been very helpful!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.