PHP error after module update

Hello, on a FreePBX 14.0.13.23 server i updated the modules listed below and as usual the red button Apply Config appeared in top right corner.
I pressed it and got this error message:

exit: 255
Unable to continue. Call to undefined function FreePBX\modules\Core\Drivers\version_min() in /var/www/html/admin/modules/core/functions.inc/drivers/PJSip.class.php on line 499
#0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(383): Whoops\Run->handleError(1, 'Call to undefin...', '/var/www/html/a...', 499)
#1 [internal function]: Whoops\Run->handleShutdown()
#2 {main}

Module Updates:
System Admin 14.0.38.6
Calendar 14.0.3.9
Core 14.0.28.34
IVR 14.0.9.6
Asterisk SIP Settings 14.0.27.22
Voicemail 14.0.6.10

System Updates:
sysadmin.noarch 5.6-5.6.42.sng

I did a grep “version_min(” /var/www/html -r and it is only found as call in
/var/www/html/admin/modules/core/views/trunks/pjsip.php
/var/www/html/admin/modules/core/functions.inc/drivers/PJSip.class.php

but there is no definition of this function.

Sadly there is no update for FreePBX Framework.
Current version is 14.0.13.23

I can see in FreePBX source 14.0.13.24 file admin/libraries/utility.functions.php the definition of version_min() but 14.0.13.24 is not available to me. I am checking in Admin > Module Admin > Module Updates. Repositories=Standard Check Online

See below:

Review the linked post again @miro_igov, I made some edits.

FreePBX Core module ver. 14.0.28.34 requires Framework module version 14.0.13.24 or higher.

But Module Update does not know about this dependency :smile:

[[email protected] /]# fwconsole ma list | egrep "core|framework"
| core                 | 14.0.28.34 | Enabled                           | GPLv3+      |
| framework            | 14.0.13.23 | Enabled                           | GPLv2+      |

Review the post again. All the information you need to upgrade framework to 14.0.13.24 is there.

Sure, i did it and now it works. I just wonder why the updater allowed such an error. Is it bug ?

I have experienced the same error today. Just so I understand, to resolve this I need to install the edge version of the framework?

As of right now, yes.

Ok, thanks for the update. I will hold off upgrading the rest of our systems until this is resolved.

Thanks again!

update did not work…

±-----------------------------------------------------------+
| Your system is currently up to date! |
| Your PBX is up to date. |
| Also 1 Disabled module. |
±-----------------------------------------------------------+
[[email protected] ~]# amportal a ma update framework

Please wait…

!!!amportal is depreciated. Please use fwconsole!!!
forwarding all commands to ‘fwconsole’
No repos specified, using: [extended,commercial,standard] from last GUI settings

framework is the same as the online version, unable to upgrade
Updating Hooks…Done
[[email protected] ~]# amportal a r

Please wait…

!!!amportal is depreciated. Please use fwconsole!!!
forwarding all commands to ‘fwconsole’
Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 255
Unable to continue. Call to undefined function FreePBX\modules\Core\Drivers\version_min() in /var/www/html/admin/modules/core/functions.inc/drivers/PJSip.class.php on line 499
#0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(383): Whoops\Run->handleError(1, ‘Call to undefin…’, ‘/var/www/html/a…’, 499)
#1 [internal function]: Whoops\Run->handleShutdown()
#2 {main}

[[email protected] ~]# fwconsole ma list | egrep “core|framework”
| core | 14.0.28.34 | Enabled | GPLv3+ |
| framework | 14.0.13.23 | Enabled | GPLv2+ |

is this the correct version of the upgrade command?
ma upgrade framework --edge

Everything you need is in the post that’s linked above. This one: Reload Error

Was hard to see the original…thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.