Phones won't subscribe to BLF

I’m trying to switch from an onsite FreePBX box to a cloud-hosted PBX, and I can’t get BLF to work with the new setup (they were working fine with our local rasPBX).

All our phones are behind NAT and are connecting to a remote FreePBX server on FreeBSD with Asterisk 1.8.

When I run “core show hints”, the correct status of all the extensions is displayed, but it says “Watchers 0” for each of them - so the phones are apparently not subscribing to the hints.

The phones are Aastra 6757i and are using RFC 3581 to work around the NAT. Calls work fine and the server knows the status of each phone, but it’s not reflected on the phones.

“sip show subscriptions” says “0 active SIP subscriptions”.

What am I missing?

Do you have SIP ALG turned on or off on the router? To be honest the only way I got BLF to work on my local network was by disabling it. It had no effect either way on voice or registration, it just broke BLF.

Yes, I do have the SIP ALG turned off on the router (an ASUS RT-AC66U).

I finally figured it out. OSS End Point Manager included an ancient version of the Aastra firmware. By overwriting the provisioning firmware file with the newest firmware, I fixed this issue and our BLF now works.