Phones will not register with new password setup in FreePBX

Hello All,

I have Polycom IP 330 soundpoint, I have update mine freepbx, the problem is Freepbx newer version only take two letters and two numbers as secret key for extension which is driving me crazy to setup Polycom phones, Polycom phones only take numeric as a password for their lines.

I have setup a my extension without secret key (password) it will allow polycom to register with Trixbox/Freepbx but with secret key and two numbers and two letters Polycom wont register with Trixbox/Freepbx I have Weakpassword detection disable as well.

Please help and let me know how I can fix this.

This is not accurate, Polycom secrets can be alphanumeric.

They are not registering for some reason I have no idea why… I have enter the password like 321654test

and when I try to save that password in Polycom phone they reboot but not registered with Freepbx, they were working fine wit just password like 321654

Please Help

running firmware
will update and see if that fixes, please reply if you have got this fixed already. Thanks,

although also upgrade BootRom, which formatted the filesystem, so new config is on the phone as well, in any case, it seems upgrading is the way to fix this issue (not a freepbx issue)

Thanks Mikael! Im reading up on how to update firmware now which is out of date. I hope it helps thanks again.

Update the firmware on the phone? It is my best guess, we only have one Polycom (IP-5000) and that phone accept digits and characters.

Did you figure this out toweldepot? I am having a similar issue. Our Polycom 331 & 550 phones will not register if I change the secret to anything other than the 8 string pass created when the system was originally built by our phone tech. I have tried both simple and complex strings and nothing I’ve tried seems to work. The phones simply won’t register with any secret other than the original. I use the polycom web utility to change the “Auth User ID” and in PBX I change the “secret”. Is there another place in the phones or pbx to change the secret that I am missing? Someone hacked our system and I need to change these asap. Any help is much appreciated.

I’m working on a Polycom 601, and editing the polycom config files directly. The phones will register if I set the secret to blank as well as the polycom’s “auth.password” to blank - the register. Without FreePBX, and just using straight Asterisk, I can put a simple numeric password. But FreePBX requires me to add two letters! It won’t let me enter anything else. I am running bootrom 4.1.4 (firmware 3.1.8 legacy release) at the moment. This is making me not want to use FreePBX. Is there no way to avoid the complexity requirement on the secret?

Ah, I’ve even tried disabling the WeakPasswordDetection module, and that didn’t help.

So I (made a copy of) and edited the file at \root\var\www\html\admin\assets\js\pbxlib.js and searched for the function called weakSecret() and in the pard where it does the password.match, I removed the clause that required the letters in the string, so that it now reads:

if(password.match(/\d\D*\d/)==null){alert(fpbx.msg.framework.weakSecret.types);return true;}

Thus I was able to save (and it is retained) the secret and it allowed me to Apply Config just fine.

But even after I rebooted the phone, it still didn’t register.
Ah, this is a headache.

Well, actually, there is a real option for disabling the secret! It isn’t necessary to hack the interface anymore.

However, even though I’ve set the secret to match the polycom auth.password, it doesn’t register, saying the password is wrong. The password for the user in FreePBX is the same as the secret and the polycom password.

What am I missing?

I have no issues with a polycom 335 using a secret of this format:


Running firmware 4.1.0

BTW - this was a thread from 2010…

For the thread - I am so used to stack exchange where you get downvoted and closed if you have any breath of similarity between questions…

I finally figured it out. In the polycom settings, the reg.1.address and reg.1.auth.userId must be the same, and must match the Linked User in the FreePBX settings. After that, then the secret will work when it matches the reg.1.auth.password.

On the phone I forgot to put @ in the phone extension i.e. [email protected]
6101 extension server