Phones Unable to Receive Inbound Calls after switching to Fiber

Hello,

I have a FreePBX instance hosted with Vultr that is working great. At my home office I have a few IP Phones (a Grandstream WP820 and 3 Aastra/Mitel 6869i phones) and an Adtran T924e channel bank to serve a couple of analog phones.

Earlier this week I upgraded my internet at home from AT&T Uverse VDSL (delivered via their BGW210 modem/router in IP Passthrough mode and handed off to my SonicWall) to AT&T 1gig Fiber (delivered via their BGW320 modem/router in IP Passthrough mode handed off to my Sonicwall). After upgrading my phones will register and can make outbound calls, but cannot receive inbound calls.

If I connect one of the devices to be directly on their modem then I can receive incoming calls, but not behind the SonicWall. I have SIP ALG turned off on the AT&T modem, however it seems that it is still doing something weird with the SIP packets. Has anyone run into this after upgrading from AT&T Uverse to Fiber?

Thanks,
Daniel

If you can now receive calls when plugging directly into the AT&T modem/router then it sounds like a Sonicwall config issue.

Have you looked at the session coming in on both your AT&T router and your Sonicwall to see where its being held up?

Some solid SW info in this thread: Happiness With Sonicwalls - It can happen!

Make sure you turn off SIP transformations in your Sonicwall. That is the most likely cause of inbound call failure.

You also need to configure a firewall rule containing your endpoints with an increased UDP timeout so your phones don’t go unreachable.

Hi All,

Thank you for all of your responses. I apologize for the delay in responding as it has been a busy few days.

Everything in the SonicWall turned out to be fine. I had used the guide mentioned above when I set it up years ago. The problem turned out to be the new AT&T modem. AT&T doesn’t allow for a full bridge mode, but rather a pass-through mode; which unfortunately means that the modem is still doing some NAT. Even though I had reset the NAT tables in the modem, which is supposed to clear any open connections, it did not. After doing a hard restart on the modem everything seems to be working fine now.

Thank you again for all of your assistance!

-Daniel

The IP passthrough setting in those AT&T modems is a bridge mode, but only to the device it is passing through to. This would normally be the MAC address of your SonicWall.