Phones intermittently going "No Service"

I’m using a system that has 17 extensions, all of them Aastra phones - most are the 480i, some are the 57i. There’s been an ongoing issue that causes the phones to randomly not work. They say “No Service”. It’s very inconsistent. I’ve tried all I know to do to fix the problem.

I didn’t set the system up, so when I started looking into the problem. Some of the phones were set to DHCP and some were static IPs. NAT was turned on on the DHCP addressed phones. On the panel screen of FreePBX some extensions were greyed out, or I could watch them grey out at random times.

I switched everything to use DHCP and NAT - then all of the extensions had a green light on the FreePBX panel. And it worked finr for the rest of the day, but now it seems like the problem is worse.

Also, many of the extensions say (unspecified) under the host column.

Here’s the SIP Registry if it helps:

Name/username Host Dyn Nat ACL Port Status
VP-/*** 5060 OK (71 ms)
VP-/*** 5060 OK (18 ms)
1302/1302 D N A 1029 OK (167 ms)
1207/1207 D N A 1067 OK (117 ms)
1206/1206 D N A 1026 OK (113 ms)
1205/1205 (Unspecified) D N A 0 UNKNOWN
1204/1204 D N A 1038 OK (112 ms)
1203/1203 D N A 1069 OK (144 ms)
1202/1202 D N A 5060 OK (100 ms)
1201/1201 D N A 5060 OK (85 ms)
1108 (Unspecified) D N A 0 UNKNOWN
1100/1100 D A 5060 OK (168 ms)
1010/1010 D N A 1026 OK (115 ms)
1009/1009 D N A 1026 OK (130 ms)
1008/1008 (Unspecified) D N A 0 UNKNOWN
1007/1007 D N A 5060 OK (84 ms)
1006 (Unspecified) D N A 0 UNKNOWN
1004/1004 D N A 5060 OK (195 ms)
1003/1003 (Unspecified) D A 0 UNKNOWN
1002/1002 (Unspecified) D N A 0 UNKNOWN
1001/1001 D N A 5060 OK (62 ms)
21 sip peers [15 online , 6 offline]
Verbosity is at least 1

Thoughts? Ideas? Suggestions? Any help or input would be greatly appreciated.

Forget about panel screen and lights! Go to asterisk CLI and check sip debug.

I have seen this issue on Aastra endpoints. With some older firmwares, if the endpoint can’t reach one of the ntp servers you have configured, then it would go “no service”. The fix is to make sure you have one and only one very reliable ntp server (I use the PBX since it is local to my LAN) and investigate updating the phone firmware. As far as updating Aastra firmware goes, do not assume that the latest is the greatest. I have standardized all my 67xx series phones on, but I have no personal experience with the 480i so I can’t advise as to the firmware on those.

If you have a large amount of multicast traffic on your network (think Sharepoint or large Netbui over TCP deployment) this will also cause this issue.

VLAN’s won’t solve it if you are using the PC port on the phone as the LAN (802.1q trunk) port will still be having to forward the multicast traffic to the PC port.

Most enterprise and some small business switches have broadcast/multicast storm control options for this very purpose.

Your PC users will report it as slow access. If the phones miss a qualify window they will say “no service”

Thanks I will!

Here’s one for you. Sometimes I need to wait a few minutes when accessing the Asterisk control panel. It takes 3-5 minutes to load, then after I’m in it works fine.

Ok so specifically the home page. If I click the Home link on the Asterisk menu. The takes a long time for the request to process and it won’t load any other pages until it finishes.

Something is terribly wrong. Either your network is severely overloaded or impaired and you are discarding packets (causing retransmissions) or your server is busy and can’t service the interface or the http requests.