Phone will not re-register when power is restored


(Hezner) #1

Our office phone system uses Yealink T41S phones, a FPBX instance running on Vultr, and Skyetel SIP circuits. The office router/firewall is an Edge Router. SIP communication through our router is a public to private nat. Everything has been up and working fine for months. We have had to do the occasional reboot on the phones and the usual updates on FPBX. DHCP is set with the 66 option and has worked fine.
Thursday night the carpets were being shampooed so the computer and phone in the larger conference room were unplugged and moved out of the room. Friday when the computer and phone were moved back into the room and reconnected, the computer reconnected fine but the phone did not.
When the phone was plugged in it went through the typical rebooting / initializing sequence. However it said network unavailable while booting and ended up with “Warning No Service” on the screen and the status “account unregistered”. The IP address, MAC, and firmware are all showing correctly on the phone. If I unplug the network cable, the IP address blanks out on the phone status display. We rebooted the phone several times with no change. We changed the patch cable and network port with no change. We tested a spare phone which is configured for an extension that we are not currently using in the large conference room and got the same issues with it. I tried factory defaulting the large conference room phone and then letting it try to auto-provision but just ended up with a factory defaulted phone.
I tried taking the large conference room phone to the small conference room, unplugging the phone that is in the small conference room and plugging the large conference room phone in there. The large conference room phone did not auto-provision. When I plugged the small conference room phone back in to the same port, it booted up to the “warning no service” and “account unregistered” status.
All the other phones in the office are working fine and we are able call out and receive calls just fine. I was able to log into the web page for the small conference room phone. All settings looked fine. I was able to reboot the phone from the web page. From the web page I was able to click the auto-provision now button and on the status tab on the web page see it say registering but it still failed to re-register. Checking the DHCP server shows the DHCP service working and shows the extension that was factory defaulted with the phone model instead of the extension. The FPBX server dashboard shows those two extensions off line. Between the time that the phone was originally unplugged and then repowered, there were no changes to anything (phone firmware, DHCP server, FPBX server, router).
Based on my trouble shooting so far I do not believe that the problem is with physical infrastructure (cabling, ports, switches, etc.) Given that the DHCP server saw the phone change to factory default and that the IP address goes away when the network cable is unplugged, I believe that the DHCP is working properly. Given that all the other phones are able to send / receive calls as expected and that the FPBX dashboard saw the status change to those two extensions, I believe that the router, SIP, and FPBX are all working OK.
What am I missing? Has anyone else seen anything like this? What do I try next? Thank you in advance for any thoughts. Pat


(Jared Busch) #2

Vultr, FreePBX, Yealink phones, Skyetel, and an EdgeRouter? Sounds like most of the clients I set up.

So first things first, Are you using TLS or UDP?

If UDP, then fire up sngrep and look for register packets from the extensions.

If using TLS, the built in sngrep cannot see it.

The next best thing to look for is for the provisioning requests to hit the web server. This tells you that at least the phone is getting out of your network and hitting the PBX.

tail -f /var/log/httpd/access_log

Then you can use the pcap tool built in to SysAdmin to capture data and look for the registrations.


(Hezner) #3

Thank you Jared. It is using UDP. I’ll do as you suggest and see what more I can discover.
And you did help me finish my FPBX set up when I got stuck and was hitting a deadline. Thank you again for that.


(Hezner) #4

Update - sngrep did not show the REGISTER packets coming in to FPBX so my problem is elsewhere. Then this morning all the other phones in the system showed up with the same problem. I did test sending via TCP instead of UTP and also tested increasing server trys, neither of which worked. I also updated and rebooted the FPBX server. It had updates that came in after the 2 conference room phones failed to register which I had been holding off applying . Since I can’t reboot the router/firewall during the day, for a short term fix I have helped people log into their user control panel and forward their extensions to their cell phones. This will buy a bit of time while I work on finding and fixing the problem.


#5

Definitely sounds like a firewall issue. Unfortunately I’m not familiar with and EdgeRouter but there should be traffic logs there you can have a look at to see if it’s blocking traffic in either direction. It sounds like the firewall is blocking whatever provisioning you have set up. This is why the conf phone failed first, you took it offline and it tried to provision when it came back up.

As for the other phones, perhaps there was a power blip overnight that caused all of them to reboot and thus encounter whatever new problem the EdgeRouter may have put in your way prior to the conf phone issue surfacing.


(Hezner) #6

I was able to reboot the router/firewall last night and revert it to the previous configuration. I had only added a couple of firewall rules for upcoming sites which should not have impacted anything. That did not solve the problem. Tonight I’ll revert the firewall back one more configuration (don’t think any changes from where it is now) to a state where I know the phones were able to register and auto provision properly and will turn on more logging so I can do a bit more troubleshooting. People are managing OK with their extensions forwarded to their cell phones and I have deadlines on two other projects so will have to wait will this weekend to get into this further.


(Hezner) #7

I went back into FBPX this morning and applied the new set of system and module updates and loaded the newly reissued LE certificate. The “fwconsole restart” and “fwconsole start Restapps” did not seem to run cleanly. Neither the UCP or the Xmpp Daemons were started. I then re-ran “fwconsole pm2 --list” and confirmed that they were stopped so re-ran “fwconsole restart” and everything started OK this time AND all the office phones registered properly and are back on line. I don’t believe that the FPBX dashboard showed the problem with UCP or Xmpp Daemons after the updates were applied and the server restarted last week but can’t prove it at this moment. Just really pleased that everything is working properly again.


(system) closed #8

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.