Phone will not provision with EPM - Manual provision works fine

I have been trying to get a Grandstream GXP-2130 to provision. I have followed all of the steps to configure the EPM, create the template, and extension mapping found on the Configuring a Phone Using EndPoint Manager (EPM) page on the FreePBX wiki.

When the phone attempts to register, I get the following in the Asterisk logs:

[2022-11-29 13:38:03] NOTICE[24887] res_pjsip/pjsip_distributor.c: Request 'SUBSCRIBE' from '<sip:MAC%[email protected]>' failed for '' (callid: [email protected]) - Failed to authenticate

This message does not change at all even though I have attempted many different provisioning methods. I have enabled TFTP - same error message. I have enabled password protection for HTTP(S) and included the HTTP username and password on the provisioning request - same error message. I have removed the HTTP authentication - same error message.

I can manually provision the phone without a problem. The problem seems to be when using the provisioning template I created in the EPM. Any thoughts?

I am trying to use the EPM to save time before I provision the rest of the phones in our two offices. Would prefer a solution that allows me to use the purchased EPM module and avoids manually provisioning a ton of phones. Thanks in advance!

I’m running into the same issue. What version of EPM are you running?

Oh, too bad!! My version is 16.0.71. What are you running?

Same. It appears when you rebuild your configs EPM creates a 1KB cfgc file. If you roll back to an earlier version a normal size file is created. Same is true of the latest V15 EPM module

@mvogel4949 that is a great find. I just purchased this, so I’m not sure how I would roll back to a previous version. I’ll start researching to see how I can do that.

@mvogel4949 you got the wheels turning in my head. I wonder what would happen if I just delete the configs and create a new config to apply to my extension. In theory it should create a new cfgc file with a normal file size. Have you tried something similar to that?

It won’t work at the current version. You can go to previous versions of EPM in Module Admin

1 Like

Got it. Thanks for the heads up. I’ll give that a try.

I have a ticket going with Sangoma. They have confirmed the issue on V15, looking at V16 now.

It works!! I am using! Thanks for the suggestion. I have been fighting this for hours.

16.0.71 had the issue, but I rolled it back to and it seems to be working

Please try with below latest EPM release and if still not working , please raise the issue. thanks
Endpoint v16.0.72
Endpoint v15.0.55


1 Like

V16.0.72 does now seem to be creating the proper cfg files for the Grandstream phone which is great. I am still receiving an error though when I attempt to Save, Rebuild and Update phones from the template page. If I do the same from extension mapping, no problem.

Whoops\Exception\ErrorException thrown with message "A non-numeric value encountered"

#6 Whoops\Exception\ErrorException in /var/www/html/admin/modules/endpoint/
#5 Whoops\Run:handleError in /var/www/html/admin/modules/endpoint/
#4 endpoint_write_grandstream_ext in /var/www/html/admin/modules/endpoint/
#3 endpoint_write_ext in /var/www/html/admin/modules/endpoint/
#2 endpoint_rebuild_template in /var/www/html/admin/modules/endpoint/views/page.endpoint.php:406
#1 unknown in /var/www/html/admin/modules/endpoint/page.endpoint.php:10
#0 include in /var/www/html/admin/config.php:647

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.