FreePBX | Register | Issues | Wiki | Portal | Support

Phone keeps ringing even after hanging up


#1

I have a ring group set with an announcement. When I call this number it rings, the announcement is played and all phones start to ring. When I hang up however the phones keep ringing several times. When I remove the announcement from the ring group this is not the case, so the phone stops ringing immediately after hanging up.

The announcement comes from a system recording, but does not have a destination set under “announcements” because it does not have a destination.

Any way of trouble shooting this? community.freepbx.org/log.txt


(Lorne Gaetz) #2

That’s strange. Does the same thing happen when you call the ring group from an extension instead of using a trunk?


#3

I can’t test this since I apparently created the ring group with the external number as ID so I created a new group, same settings and tested that. It was not the case. Maybe the solution is to delete and recreate the ring group. I will try that later this week.


(Itzik) #4

What happens when you dial the ring group number from an internal phone?


#5

So I created a new ring group with an ID of 500, same settings as the old ring group. When calling an external line and hanging up, the phone keeps ringing. When calling 500 from an internal line, ringing stops instantly on hanging up.


(Itzik) #6

OK, so one post before your last post, you said that when you created a new ring group with the same settings it works fine. in your last post you said that it doesn’t work when you use the same exact settings.
Can you please clarify what is happening when you create a new ring group with the same settings?

Two more steps i’d try.

  1. Point a DID directly to an extension, call the DID and see if it also rings after you hang up.
  2. Check if 10000-20000 is open to your PBX.

#7

Your log seems to show a networking problem, not related to the ring group. Answer(“SIP/cheapconnect-00000019”, “”) is executed, so that the announcement can be played to the caller. But the expected ACK response to the 200 OK never arrives; chan_sip does several retries and gives up 31 seconds later. The BYE request would be sent over the same path, so it’s also not received and the phones ring for the full 20 seconds. (When you don’t have an announcement, there is no Answer until an extension is picked up. When the caller hangs up, cheapconnect sends a Cancel over the same path as the original INVITE, so the problem does not occur.)

Unfortunately, this theory has a major flaw – I’d expect that if the caller does not hang up and and the call is answered at one of the extensions, it would be dropped after ~31 seconds. If that issue were present, it would have been your major complaint, so I assume that normally answered calls are ok. However, I’m curious if the BYE still doesn’t get through. Make a test call to the external number, answer it at one of the ringing extensions, then hang up the calling phone and report whether the extension immediately shows the call as disconnected.

If this a networking issue, please report:
Is PBX on-site or in the cloud? If the latter, with which provider?
Is it on a public IP or behind a NAT?
In General SIP Settings, are External Address and Local Networks properly set?
Did you try the cheapconnect trunk with pjsip and have trouble?
Which hardware firewall, if any?
If using firewalld, iptable or another software firewall, what special settings have you implemented?


(Lorne Gaetz) #8

Ring groups are configured by default to send a SIP 183 PROGRESS packet. I suppose it is possible that your provider is not happy with receiving 183 PROGRESS and then immediately getting the 200 OK Answer. You can try disabling the progress option in the Ring Group config. If that doesn’t work, you could also try routing the call through an Announcement before routing to the ring group.


#9

@Stewart1 the PBX is onsite in a virtual machine. It’s behind a firewall (so NAT, Edgerouter Lite btw), no firewall on the virtual machine. I checked the IP settings (my IP changed last week, forgot about that), updated the settings, and now I can’t even be called :slight_smile:

@lgaetz Disabling the progress option did not do the trick. I also tried routing through an announcement, without success.

[edit]think the ip changing thing did solve the issue![/edit]


(system) #10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.