Phone Ear Piece Mutes when User talks

During a conversation the 9133i’s ear piece temporarily mutes when the user makes a sound into the 9133i’s mic. For example, User A is using the 9133i SIP phone. User B is using a cell phone. When User A calls User B, User B starts talking. If User A starts talking or breathing into the mic while User B is talking, User B is temporarily muted until User A stops making noises.

This is problematic during conference calls. When a listener sighs, all of a sudden they don’t hear the conference call and they miss an important detail.

At first, this was happening for all calls, internal calls between extensions and external calls over the TDM card. I set the “canreinvite” option on all extensions to yes which greatly improved the situation. Now, internal calls between extensions do not mute the ear piece while the user is talking. However, external calls are still affected. Does anyone know how to ensure both sides of the conversation are transmitted and not blocked regardless who is talking?

System Specifications:
[] FreePBX 2.4.0
] Asterisk
[] Digium TDM808B (0 FXS Ports/8 FXO Ports) - Only 5 are in use for outgoing calls
] Aastra 9133i SIP Phones

Thanks in advance.
Scott Cupit


We have 9133i’s and have never had that happen. We do large conferance calls every week (20 people) and have never had anybody say that.

Post the aastra.cfg, and .cfg files you used to configure the phone along with what version of the firmware you are using. Let see’s if there is anything that I can see that sticks out.


File:“aastra.cfg” file

DHCP Setting


dhcp: 1 # DHCP enabled.


0 = false, means DHCP is disabled.

1 = true, means DHCP is enabled.


Network Settings


#subnet mask:
#default gateway:
tftp server:
download protocol: TFTP
sip transport protocol: 0

Additional Network Settings:


web interface enabled: 1

#sip registration time: 300 # Eg. every 300 seconds, a re-register
# request is sent to the SIP server.
#sip rtp port: 3000 # Eg. RTP packets are sent to port 3000.

sip silence suppression: 2 # “0” = off, “1” = on, “2” = default


SIP registrar and Proxy Server Settings


sip proxy ip: # IP of proxy server.
sip proxy port: 5060 # 5060 is set by default.
sip registrar ip: # IP of registrar.
sip registrar port: 5060 # 5060 is set by default.

Time in seconds before which the phone automatically

starts calling the dialed number

sip digit timeout: 4


Time Server Settings


time server disabled: 0 # Time server disabled.
time server1: # Enable time server and enter at
#time server2: # least one time server IP address.
#time server3:
time format: 0
date format: 7
time zone name: US-Pacific
time zone code: PST
dst config: 3

Time Server Disabled:

0 = false, means the time server is not disabled.

1 = true, means the time server is disabled.

Notes: If the time server is enabled you will need to enter the

IP address of at least one time server. If the time server is

disabled, the time can be set manually in the phone’s Options

List under option “2. Time and Date”.


Line Settings


Lines should be set in the .cfg file since these settings

are unique to each phone. See the sample “.cfg” file for

for more information.


Programmable key Settings


Programmable keys can be set either server wide or unique to each phone.

Setting programmable keys as done in the “.cfg” file are

unique to each phone.

Notes: There are a maximum of 7 keys that can be configured

on the 9133i phone. These can be set up through either of the 2

configuration files, depending on whether this is to be server

wide (“aastra.cfg”) or phone specific ("[mac].cfg").

Each key needs to be numbered from 1 - 7, for example

“prgkey7 type: speeddial”. Programmable keys can be set up as speeddials.

PRGKEY TYPE: “speeddial”

PRGKEY NAME: Alpha numeric name for the programmable key.

The maximum number of characters for this value is 10.

PRGKEY VALUE: Any DTMFs (from # 0 - 9, *, "

") or a comma (,) for 500ms pause and

‘E’ for On-hook can be set for the value.

prgkey1 type: speeddial
prgkey1 label: "Voicemail"
prgkey1 value: *97

prgkey2 type: speeddial
prgkey2 label: "Call FWD On"
prgkey2 value: *72

prgkey3 type: speeddial
prgkey3 label: "Call FWD Off"
prgkey3 value: *73

#prgkey4 type: speeddial
#prgkey4 label: “CallFwdOff”
#prgkey4 value: *73

#prgkey5 type: speeddial
#prgkey5 label: “DND On”
#prgkey5 value: *78

#prgkey6 type: speeddial
#prgkey6 label: “DND Off”
#prgkey6 value: *79

#prgkey7 type: speeddial
#prgkey7 label: “CLIDBlock”
#prgkey7 value: *67



Global Settings


sip screen name: Scott Cupit
sip display name: Scott Cupit
sip user name: 1003
sip auth name: 1003
sip password: 111111

Line Settings


sip line1 auth name: 1003
sip line1 password: 111111
sip line1 user name: 1003
sip line1 display name: Scott Cupit
sip line1 screen name: Scott Cupit

sip line2 auth name: 1003
sip line2 password: 111111
sip line2 user name: 1003
sip line2 display name: Scott Cupit
sip line2 screen name: Scott Cupit

sip line3 auth name: 1003
sip line3 password: 111111
sip line3 user name: 1003
sip line3 display name: Scott Cupit
sip line3 screen name: Scott Cupit

Programmable Key Settings


Programmable keys can be set either server wide or unique to each phone.

Setting programmable keys as done in the “.cfg” file are

unique to each phone.


Do you think this could be a asterisk/freepbx related?

Here is the version information you requested:

Aastra 9133i
Network Status
Attribute Port 0 Port 1
Link State Up Up
Negotiation Auto Auto
Speed 100Mbps 100Mbps
Duplex Full Full

MAC Address: 00-08-5D-1B-EC-88

Hardware Information
Attribute Value
Platform 9133i Revision 0

Firmware Information
Attribute Value
Firmware Version
Firmware Release Code SIP
Boot Version
Date/Time Sep 17 2007 15:12:26


I’m dealing with this issue on a TDM410P. It appears to be an issue with echo cancellation. My specifics are different from yours, but the symptoms are the same.

You can try temporarily turning off EC to see if it fixes the issue. You may have terrible echo problems when you do that, but you should be able to see if the muting problem goes away. If it does, then you’re going to have to experiment with other EC options.

My next step is trying HPEC from digium, even though I have their EC card (engineering claims that it’s causing the problem and should be fixed in firmware soon.) Anyway, you may be entitled to HPEC licenses for your card, I’d try that if you’re using OSLEC or MG2 or some other free one.

You hit it dead on!

The echo cancellation card is causing my problem. When removed the card, the muting stopped and i could hear both sides of the conversation regardless who is talking. Yet as you stated, I heard a good deal of echo. I am contacting digium about this and will post once I have a solution.

Thanks Everyone!

If you are using OSLEC you need to watch your zapata*.conf settings (also get them removed in the trunk settings for the zap setup). You want echocancel=on or yes but NEED to comment out echotraining= as enables a second echo canceler and between the both they fight. somewhere in the OSLEC doc’s it tells you this. It’s just not very clear and you’d think that it could scan the file for echotraining= and atleast issue a warning to remove it or have issues if it see’s it so you’d know.


Here is a detail that you should have.

When doing more then sip setup per Aastra you need to add these lines for each additional line:
sip line? proxy ip:
sip line? registrar ip:
where ? is the line number