Perl-CGI fails dependencies

I am attempting to install System Statistics for Webmin under FreePBX version 6.12.65-27, but it requires perl-CGI. Unfortunately, attempting to install the perl-CGI package gives me this:

[*@phone log]# sudo yum install perl-CGI
Loaded plugins: fastestmirror, kmod, priorities, security
Setting up Install Process
Loading mirror speeds from cached hostfile

  • webmin:
    177 packages excluded due to repository priority protections
    Resolving Dependencies
    –> Running transaction check
    —> Package perl-CGI.x86_64 0:3.51-136.el6 will be installed
    –> Processing Dependency: perl = 4:5.10.1-136.el6 for package: perl-CGI-3.51-136.el6.x86_64
    –> Finished Dependency Resolution
    Error: Package: perl-CGI-3.51-136.el6.x86_64 (base)
    Requires: perl = 4:5.10.1-136.el6
    Installed: 4:perl-5.10.1-136.el6_6.1.x86_64 (@updates)
    perl = 4:5.10.1-136.el6_6.1
    Available: 4:perl-5.10.1-136.el6.x86_64 (base)
    perl = 4:5.10.1-136.el6
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

Attempts to add priorities to the repositories (as suggested on other sites) didn’t help, and it’s not worth the trouble to start rolling back packages to earlier versions. Any thoughts?

That’s trying to use the Webmin repository. That’s your problem. Disable that repository, as it’s out of date.

Also, don’t install webmin on your PBX :sunglasses:

Edit: Oh, sorry, I misread. You’re DELIBERATELY trying to install webmin on your machine. That’s a bad idea, but, if you insist, you’ll have to roll back your perl version to whatever their perl-CGI requires.

This is a problem with Webmin’s RPM repository, and you should be asking them to update their RPMs.

Thanks for the reply. I uninstalled Webmin completely, deleted the repo configuration, ran “yum clean all” and “yum update”, but I get the same error.

Also, why do you not recommend using Webmin on a FreePBX distro? I mostly use it for hardware and service monitoring, so I’m not too worried, but I’d hate to trip on any landmines later.

Anyone else have any thoughts?

Did you get your rpm from :-

? IWFM on various redhat systems up to and including 7.

I guess it might not recognize your OS as RedHat based, perhaps go the “old fashioned way” with the tarball as documented at the bottom link in:-

I suggest you change the ports in /etc/webin/miniserv.conf and enable the fail2ban webmin jail , if you are extra paranoid only run it when you need it.

There has long been a generally unsubstantiated rumor that it is insecure but

might persuade you otherwise

I tried to install Webmin through the Webmin repository, but I think Webmin is a red herring. If I manually try to install perl-CGI from the FreePBX repositories, I get the same error, with or without the Webmin repositories enabled.

Then as I suggested go the “old fashioned way”

I guess I didn’t explain it well. Webmin itself isn’t the problem. I can get that to run just fine. However, there is a Webmin module, Sysstats, that requires perl-CGI to work. However, when I try to install perl-CGI from the command line, I get the error above where perl-CGI requires perl-5.10.1-136.el6, but what is installed is perl-5.10.1-136.el6_6.1. The only difference is that the installed version of Perl is slightly newer than what perl-CGI is asking for.

Another old-fashioned way might be to do it with perl itself with the help of cpan if that is available

cpan CGI