Peer's Certificate Expired when doing Freepbx Activation

I am new to Freepbx. I have installed the latest version but i have problems in activation. Activation error: peer’s certificate has expired

Issue resolved. Before activating, your Freepbx will communicate with sangoma servers to innitiate the activation process. The Server will not do this if your TIME and DATE as well as time zone is wrong and your current location time is wrong. You will need to correct the time and date to ensure that the server does not flag your system as expired certificate. to do this, go to the computer system running freepbx or remote using Putty or any ssh. login with credentials and do as follows

  1. first check current date and time by typing the command and hit enter
    timedatectl status

The current time and date may likely be wrong, change it by typing the next command and hit enter

  1. timedatectl set-time “2017-10-25 09:41:00”

NOTE: If your changes are not effected and the system says time sync should be disabled, use command
timedatectl set-ntp 0

To set the time zone use the command, using your location, as example;
timedatectl set-timezone “Asia/Kolkata” or timedatectl set-timezone “Africa/Accra”

  1. Now typre reboot to restart the system and come back to terminal to confirm the date and time has changed using command

timedatectl status