PBXact UC40 distro-upgrade fails on Yum Update

Yum update produces this error:

libsrtp-devel-1.5.4-3.el6.x86_64 from epel
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

 1. You have an upgrade for asterisk13-addons-core which is missing some
    dependency that another package requires. Yum is trying to
    solve this by installing an older version of asterisk13-addons-core of the
    different architecture. If you exclude the bad architecture
    yum will tell you what the root cause is (which package
    requires what). You can try redoing the upgrade with
    --exclude asterisk13-addons-core.otherarch ... this should give you an error
    message showing the root cause of the problem.

 2. You have multiple architectures of asterisk13-addons-core installed, but
    yum can only see an upgrade for one of those arcitectures.
    If you don't want/need both architectures anymore then you
    can remove the one with the missing update and everything
    will work.

 3. You have duplicate versions of asterisk13-addons-core installed already.
    You can use "yum check" to get yum show these errors.

…you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: asterisk13-addons-core-13.19.2-1.shmz65.1.197.x86_64 != asterisk13-addons-core-13.19.1-1.shmz65.1.195.x86_64
Error: Protected multilib versions: asterisk13-addons-bluetooth-13.19.2-1.shmz65.1.197.x86_64 != asterisk13-addons-bluetooth-13.19.1-1.shmz65.1.195.x86_64
Error: Protected multilib versions: asterisk13-addons-ooh323-13.19.2-1.shmz65.1.197.x86_64 != asterisk13-addons-ooh323-13.19.1-1.shmz65.1.195.x86_64

I have tried
rpm -Va --nofiles --nodigest
yum update --skip-broken
to no avail. I have NOT tried “–setopt=protected_multilib=false”


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.