PBXact PJSIP - How to eliminate SIP NAT from a specific trunk group


(Grandpoohbah1) #1

I have a scenario where they’re 3 trunks:

  • 2 Trunks route to the PSTN - which they detect the public IP
  • 1 Trunk routes to a VPN where only private IP addressing issued and the public routes are not advertised.

I’m having an issue where the 3rd trunk conneted to the VPN/ Private IP space is referencing the public IP for it’s contact & audio connection. Is there a way for the PBX to use it’s private IP address as it’s contact & audio connection info?

I’ve tried changing multiple settings to no avail & any help would be greatly appreciated.

Thanks

GPBH


(Lorne Gaetz) #2

Is the VPN address range(s) added to Local Networks in Asterisk SIP Settings?


(Grandpoohbah1) #3

Thanks Igaetz - Yes it is.


#4

After setting Local Networks to include the VPN address range, you must Submit, Apply Config and then restart (not just reload) Asterisk.

Possibly, this is an OS level routing issue. If the PBX has more than one NIC, if the VPN client is other than on the PBX itself, or if there is any NAT in the VPN path, provide details.

Does the INVITE with the incorrect Contact header and SDP have the correct source and destination addresses? If multiple NICs, is it being sent via the correct one?


(Grandpoohbah1) #5

Thanks Stewart1,

Although I did this before reading the latest thread, I performed a fwconsole restart , which appeared to force the “reload” and resolved the issue.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.