FreePBX | Register | Issues | Wiki | Portal | Support

PBX REJECT incoming calls, but outbound works fine


(Mrt Tommaso Pbx) #1

Hello! i’m not into everything involved around FreePBX but i managed to set up some soft/phisical phones to dialog internally and to make outbound calls,so now the problem is that i really cant get incoming calls!
if i call the number, PBX say “the number you chose is not in use

Trough the Asterisk Info page, i see that there a re A LOT of stuffs that definitly should not be like that, first of all, my gateway for POTS line say “Rejected” (TA410 with IP 192.168.0.130)

Here i’ll leave some screenshots, hope that someone can help me and thanks already for your help!


(Mrt Tommaso Pbx) #2

UPDATE

i contacted the Gateway support, we find out that the problem is PBX side, since the PBX is rejecting the incoming calls!

here is a screenshot

i can send logs if you need…


(Mrt Tommaso Pbx) #3

UPDATE allowing “Anonymous Inbound SIP Calls” solved the problem… dunno if this is the right way or whatever, but calls work perfectly!


(Lorne Gaetz) #4

More correctly it masked the problem. The problem is that the trunk between the PBX and gateway is misconfigured.


(Mrt Tommaso Pbx) #5

Citazione
More correctly it masked the problem. The problem is that the trunk between the PBX and gateway is misconfigured.

I was kinda sure about this problem…
Any advices on how to configure it propely?
Actually i dont really understand what are “trunks” …
i mean, i have a provider that give us 4 POTS that are connected to the gateway wich is connected to the FreePBX trough the local network!


#6

The trunk is the “result” of connecting your gateway to your freepbx. You have a SIP trunk to your gateway which in turn has a 4 line connection to the PSTN.

There must be a guide from the manufacturer on how to configure that particular gateway to work as a trunk with freepbx/asterisk.


(Mrt Tommaso Pbx) #7

I contacted the support of the gateway and they helped me out a lot and after varius testing and configurations we pointed out that the FreePBX is rejecting incoming call from the gateway, so we really think the problem is caused for some misconfiguration of the FreePBX
The main problem is that, from what i’ve understood on itnernet, a “SIP trunk” is a solution given from a Provider… well, the only provider i have give us the classic POTS lines, nothing else, so i really dont get what you mean when you talk about trunks!
I’m kinda sure the gateway is set up correctly since outbound calls works perfectly and he just have to convert IP singnals from PBX to classic analog signal for POTS
viceversa, for Incoming calls, the gateway converts the signals but then the PBX reject the gateway for some reason!
The gateway btw says that everything is fine in the setup and that it’s connected to the PBX

By the way yes, there is a guide, is reeeally simple and i started from that!


#8

The gateway IS your trunk. If configured correctly, the gateway will behave like a SIP trunk for freepbx. If the only way to make it work is to allow anonymous calls, then there is a misconfiguration of the trunk, either on the gateway, freepbx, or both. You need to make sure that the trunk is configured correctly on both sides.


(Lorne Gaetz) #9

The guide you followed details exactly how to set up a PJSIP trunk (which is awesome!). The problem with the guide is that it ASSUMES that the pjsip driver on the PBX is bound to port 5060 which may not be the case. You must first confirm which port PJSIP UDP is bound to (Settings, Asterisk SIP Settings, PJSIP tab) and modify the gateway config to suit.


(system) #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.