PBX Not connecting to phones

I have moved our businesse’s PBX system to a new office location. Using all the same equipment (PBX, phones, linksys router, action tec dsl modem) Using the same Qwest DSL service, and kept the same static IP address and qwest dsl account login and password.

I am able to dial into the system and transfer to outside extensions. I am not able to dial out on either of our 2 phones, or reach their extension when dialing in.

The phones are Aastra 480i and 480i CT. When their network cables are plugged into the router, the initial DHCP test does not show any errors. It appears they are connected to the pbx just fine, but are not communicating properly.

Also note that their internal ip addresses changed from xxx.xxx.xxx.101 and 102 to xxx.xxx.xxx.3 and 4.

Does anyone know why they would appear to connect just fine, but not work now?

Again note, that I have made no system config changes to the pbx or the phones themselves. Just moved and plugged in.


Has your PBX’s IP address changed? From the Linux command prompt can you ping the phones? (Ctrl C to stop pinging)

When you changed offices, I imagine that your outside IP address changed (other side of the DSL modem). It sounds like a network IP configuration/NAT problem to me. Are the phones registering with your PBX? If you dial *65, do the phones get a reply from the PBX with their extension?


Thanks for responding! I am able to ping both phones from a command prompt. No timouts.

When you state the IP address on the other side of the DSL, I assume you mean the static IP that Qwest assigned me when I got the DSL? If so no. Qwest was able to transfer the account to my new office keeping the same login, password and static ip address.

When I dial *65 from either phone there is no reply. It may also be worth noting the following:

NAT is turned on in the DSL modem, but it has always been.
In the Aastra phone firmware:

~ Link State ~
Port 0 = UP
Port 1 = Down
Negotiation Auto Auto
Speed 100Mbps 10Mbps
Duplex Full Half

~ Basic Network Settings ~
DHCP Enabled = yes
IP Address =
Subnet Mask =
Gateway =
Primary DNS =
Secondary DNS =

~ Advanced Network Settings ~
NAT Port = 0
Nortel NAT Traversal Enabled = No
Nortel NAT Timer (seconds)
NTP Time Servers = Enabled
Time Server 1 =
Time Server 2 =
Time Server 3 =

I put together a webpage on slipping SIP past a firewall, it involves some router/firewall settings and some Asterisk settings. It may have clues.

Is your PBX server running a static IP address or dynamic (using DHCP)? If it is dynamic, then maybe your phones are trying to register to the old IP address?

I have had several SIP phones that when they do not receive a proper DHCP service they use the previous setting and almost work correctly.

This section bothers me - it may be fine, I’m not familiar with the Astra:

~ Advanced Network Settings ~
NAT IP = <= shouldn’t that have an IP address?
NAT Port = 0
Nortel NAT Traversal Enabled = No
Nortel NAT Timer (seconds)
NTP Time Servers = Enabled
Time Server 1 = <= I would put your PBX IP address here
Time Server 2 =
Time Server 3 =

Lastly, did the IP address of your default gateway change? I would check both your internal router’s IP address and external IP address. And if the default gateway changed IP address, check /etc/sysconfig/network or /etc/sysconfig/network-scripts/ifcfg-eth0 to see if the GATEWAY=xxx.xxx.xxx.xxx matches.

Maybe there’s a conflict since the phones started using a lower IP address range. Could be another network device now has the same IP address as your server?