Password field for extensions goes blank

Noticed some extensions have blank password field. Create new extension to get 32 char password and copy it to existing extension, submit/reload, see a popup ‘symlink(): exists’. After it reloads, password field is still blank.

This behavior happens after enabling voicemail. Delete and recreate the extension, is fine until voicemail is enabled. Password field becomes empty and cli sip show peers, the extension is not there.

Where is this symlink which might be causing the issue?


Tried fwconsole chown. Did not rectify the issue.

There was a bug like this a while ago, are your FreeBPX modules fully up to date?

I did a restore from older backup and now it appears ok. And yes, all modules are up to date. However backup is not working. See my post there about backup php fatal error.

Add 32 character password, click submit, dialogue box pops up displaying symlink(): File exists

Any idea how to fix this? Any change to an extension causes the password to be lost and consequently the phone looses registration with the FreePBX Server.


FreePBX 13?..

Hi Tm1000,

Just deleted the extension 260. Created it again, The password is still there. Haven’t touch voicemail settings for the extension. Strange part is, in cli, sip show peers the extension 260 shows OK. But I did not change the password in the SIP phone.

Just enabled voicemail for ext. 260, click submit => symlink(): File exists

Click Apply Config and the password field is now blank.

*CLI> sip show peer 260
Peer 260 not found.

How are you deleting ?

Delete button in extension in GUI.

By the way, noticed when enabling voicemail, it creates symlink as:
lrwxrwxrwx 1 asterisk asterisk 41 May 18 01:27 260 -> /var/spool/asterisk/voicemail/default/260

however /var/spool/asterisk/voicemail/default/260 doesn’t exist.

There are several symlinks in /var/spool/asterisk/voicemail/device and most are red (non existent)

1 Like

That is completely correct.

Was going to try a full restore from one of the two .gz files on ftp server. Doing so…
Invalid backup for or undefined error

Don’t think you need to do a restore. The symlinks being invalid is correct. It’s how freepbx functions.

ok. Any idea on how to get this working again properly? Now getting message from module admin

fop2 admin and asternic cdr reports are unsigned.

There is a fwconsole command to update all forcibly isnt there?


Delete orphan devices

What command is that?


sorry I tried to be lazy because I was on a mobile device.


HI TheJames,
Ok I see all the extensions (sip phones and custom extensions). What am I looking for?