Passing caller ID to Callcentric from FreePBX 2.9

I have a handful of DIDs on my account, and I want to use for incoming calls and Callcentric for outgoing.

I have the route configured in FreePBX 2.9, and I can use it when I want with no problem. The issue I do have is I’m trying to pass along caller ID for four different numbers depending on which extension is calling. For instance, if I call from Ext. 100, 555-1000 should be the CID, Ext. 200 should be 555-2000, and so on.

In FreePBX, in the trunk settings for the Callcentric trunk, I have the CID Options set to “Allow any CID.” Then on each extension I will specify its outbound CID.

This works just fine when using my trunk. Again, using the earlier example, if I called from 100, the CID would be 555-1000. Calling from 200, and CID would be 555-2000.

When using the Callcentric trunk, the CID I specify from FreePBX does not get sent. Only the CID that I select on my Callcentric account.

I have verified my numbers with Callcentric, and they do show up. It seems like the problem is FreePBX is not sending the CID to Callcentric in a way it can use/understand.

According to the CC FAQ:

To send the caller ID number of a DID on your account or an already verified number within the SIP INVITE message of an outbound call you will need to have your user agent (UA) attach any of the following headers from highest priority to lowest priority, which are supported by most IP PBX's (check your vendor's documentation for support), to your outbound calls:


When we receive an outbound call from your UA with any of the above headers, and that header includes a caller ID number that is a DID on your account OR has been verified on your account we will pass that as the outbound caller ID for that call; over-riding any settings in your Callcentric account preferences.

Unfortunately, I’m not really sure what that means or how to add any of those to my outgoing calls from FreePBX.

One other thing I tried is adding the lines sendrpid=yes and
trustrpid=no to my PEER details of my CC trunk.

I bet this is a simple fix, but I just can’t seem to find what to change! Any help would be appreciated!


You can also enable RPID on the individual extensions. Not sure if this is necessary, but worth a try. Otherwise try doing a SIP debug to see what exactly you’re sending to your provider.

Fixed it! Callcentric support told me to add sendrpid = yes and trustrpid = no lines, but they also reminded me that the caller ID needs to be 11 digits. With, since they didn’t require the country code (1 for me, USA), I just entered in 10 digits as the caller ID.

So for an area code of 212, my solution was changing the CID entry for an extension from 2125551000 to 12125551000.