Parking Lot Problem

I’m playing with parking calls. I installed the Parking Lot module and am using it with the default settings. With those settings, you transfer a call to extension 70 to park a call. However, I am getting a “That number is not in service” recording.

Does anyone know what is going on?

I’m using parking slots very successfully - when we get an incoming call for a patient we park the call to a slot number corresponding to their room number (prefixed with 4). Then somebody walks an ICW-1000 handset to them (they could be in their room or in one of the lounges) and dials 4+[RoomNumber] to pick up the call. Works great.

These are my settings:
Parking Lot Extension: 400
Parking Lot Name: Bedrooms
Parking Lot Starting Position: 401
Number of Slots: 38 (401-438)

Can you confirm that your settings correspond to this “pattern”?

J

I’m using the default settings. So the parking lot extension is 70. Just to be clear, you transfer your calls to extension 400, right? That’s what’s not working for me. Transfers to 70 fail. But if I call 71 thru 78 I’m told no calls are parked.

Transferring to ext 70 is “attended parking” - you should hear an announcement of the slot number to which the call was parked. But you can also “blind park” a call directly to a slot, e.g 77 - does that work for you?

And I wasn’t getting the extension message from 70. The transferring extension hangs up and the invalid number recording plays for the caller.

Definitely something dodgy happening there!

Does a blind transfer to, say, 77 work?

I think you’ll need to look in the logs:

Run a test call then examine the log in Reports > Asterisk Logs (or through puTTY or similar if you’re able) - there should be some clues in there. If you are not CLI-savvy (like me) then winSCP is a useful tool - you can open log files (in /var/log/asterisk) - if you are CLI-savvy then puTTY and grep.

Maybe this:

[2016-05-05 06:13:15] WARNING[9564][C-00000106] pbx.c: No application 'Park' for extension (macro-parked-call, s, 31)

Something is happening. There are calls to [email protected] in the log.

When I dial the parking lot extension - 70 - the system tries to dial out with that number. But if I dial the lot numbers - 71 thru 78 - those are intercepted and I am told there is no call parked.

I think I’d start by uninstalling and reinstalling the Parking module.

It shouldn’t do anything, but it’s always a good first step when something goofy like this happens.

Next, in module admin, make sure the module is actually enabled.

Then, under the “Admin???” tab, double check the settings in the Parking Lot setup options.

It sounds like one of the files got screwed up and the “re-set it up” steps might be a good first step.

There were nine module upgrades this morning including core. Did that. Then uninstalled and reinstalled parking lot. Still seeing same behavior.

What do you get when you dial the parking lot extension directly? In your case 400, default 70? As I said, my system is trying to dial out. I would expect a recording.

This is not a problem with FreePBX.

The parking module in ASTERISK is not installed. You’ll need to get that loaded.

When I dial 400 I get an announcement saying “four zero one”.

Looking through Admin | Asterisk Modules I see Parking a few pages in.

Did I need to restart Asterisk after loading Parking Lot?

Considering modules autoload if you see parking anywhere in that module then that is bad.

Where did you load parking? You shouldn’t be doing this in the GUI. It autoloads.

I didn’t load it. All I did was install Parking Lot and try to work with it.

What does this mean?

Oh wait, I am on the “Excluded” tab of the Asterisk Modules interface. At the last page of this tab is “Parking.” Should I delete this?

Yes. Parking should not be excluded.

1 Like

I think that did it. I removed that exclusion and then did a ‘fwconsole restart’ just 'cause.

Now when I dial 70, I get a voice “71” back. I am testing this over a poor VPN link. So I will have to test when I am on the actual system.

Don’t know why the module was excluded. Maybe an artifact of my distro, RasPBX. I will post a possible bug on their board.

1 Like

It looks like it’s working. I called my cell phone to setup a call. After the call was established I dialed extension 70. The call disappeared from that extension. The cell phone played my on-hold music. I went to another phone and dialed 71. I picked up the call.

What I’m missing is the announcement of the parked extension number. I thought transferring to 70 should announce the parked extension but I get nothing. This may be an artifact of my physical phones however. I don’t have an option for attended/blind transfer on those physical phones. Just a transfer button. So I think it’s just doing a blind transfer and not giving a chance to play the announcement.