Parking directly to a slot instead of a Park Extension

I would like to park and retrieve directly from slots, I don’t want to waste a third line appearance as the “Call Park” button and then have 2 other line appearances for the “Slots”

I realize I could have a Park softkey, but again, why the redundancy? Can I simply be on a call, press the sd+blf line key of Slot 1, then retrieve at another phone by pressing Slot 1?


Yes. But only in FreePBX 12 and only with Attended. Blind is only supported in Asterisk 12+

Cool! Thanks Andrew, that will be a good feature and also eliminate the mistake of end users pressing the “Slot 1” key instead of “Park”

Is this still the case? I have freepbx 12.something and Asterisk 13 and I still am not able to park directly to a slot. I get “I’m sorry there is currently no call parked on that extension.” I’ve tried attended transfer and blind transfer and both produce the same message. Has something changed to make this no longer usable? Or do I have to go to some setting somewhere and turn it on?

Specifically I have Asterisk 13 and Freepbx


Still works for me. Doesn’t sound like you are transferring.

I even tried it with ##71#. I’m doing it on a polycom VVX 410 phone if that matters at all.

I parked a call directly into a slot doing exactly what you said but on a Yealink.

I still think you are doing something wrong. Please provide some logs

What log would I post? An excerpt from the /var/log/asterisk/full showing that call?

That would be excellent!

Here are the links to the files. First one is when done with ##71#. Second is done by hitting the line key on the phone which is configured as a BLF with the commercial endpoint manager. This was done on a Polycom VVX 410 phone. The ## transfer actually terminated the call.

##71# transfer

BLF line key transfer

In both files the caller is redacted as “INBOUNDCID” and the DID is redacted as DIDNUMBER

I just tried it with a Grandstream GXP 2140 and had the same results. The ## transfer to 71 hung up the call and using the programmed linekey resulted in “I’m sorry there is no call parked on that extension” The line key is programmed as a BLF. I had to hit the transfer button and then the linekey.

Hey Andrew, just wondering if you had an opportunity to take a look at my log files?

We are pretty busy with the rush to Astricon. Everything works from my end. I’ll probably be able to look at it in three weeks or so.

So I am a newbie… you can actually park calls on a single trunk?? how many??

Best wishes to all at Astricon

Did you ever get this resolved? I’m seeing the exact same issue on multiple FreePBX boxes. These have all been updated to the latest FreePBX distro and Asterisk 13.

You still planning on looking at this issue Andrew? Still having issues here with Polycom endpoints.

I am completely overwhelmed. I doubt it will get to it.