Paging (using) feature code *80 (or) paging/intercom module (phones do not hang up)


(sawgood1000) #1

Using SangomaOS (latest) from .ISO

So when using *80 feature code + extension
example: *80101 (from) x102

The 101 phone auto-answers on speakerphone.
The 101 phone hears the page from x102.
Phone x102 then hangs up …
But, phone 101 is stuck on its speakerphone, and you have manually hang up.

We’ve tried to do the same (using) the paging / intercom module.
The results are the same.

Phones involved: Yealink SIP-T29G (latest firmware)


(Jared Busch) #2

This is not paging, at all.

That is intercom.

Post logs.


(sawgood1000) #3

Thank you …
I’m speaking about paging using the paging/intercom module (with) the DUPLEX setting set to: NO

I mentioned using the feature code for paging / intercom (*80) as just another example.

In fact, in the SangomaOS UI: for feature codes:
The *80 section is labelled as Paging (not intercom)
But yet, in that section for paging: the description does say Intercom Prefix.

Either way: the paging / intercom module and/or the use of *80 (for paging) …
Yealink phones auto-answer: but do then not auto-hangup when the calling side does.

I’ll try Fanvil phones next …

Thanks for any thoughts.


(Jared Busch) #4

Yes, the functionality is part of the paging and intercom module.
But it is clearly labelled intercom.
image

Additionally, there is not any setting for duplex or not in the Paging and Intercom Module settings.
image

As the screen tells you, right at the top, this functionality is dependant on the phones.

On the other hand, if you make a page group (in other words nothing to do with intercom and *80) you have an option for a page group to be duplex or not.
image


(Jared Busch) #5

Intercom (*80) via Asterisk works by default in every model of Yealink phone I have ever touched. If something is not working for you, you have likely misconfigured your network or the phones themselves.

It is, of course possible, that your FreePBX instance is doing something wrong, but I doubt it.

Either way, in your rush to not be wrong, you ignored what I wrote.

I’ll make it even easier for you: https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(sawgood1000) #6

Jared: Thank you for taking the time to look at this with me …
It is cool you’ve shown interest.

Yes.
I was speaking about using the paging / intercom module (with) a single paging group (9000).
We’ve set the duplex option to: No

All phones on the floor (20 or so) are Yealink (same model) (latest firmware)

UPDATE:
After making a page/intercom with the module (paging group) (9000)
The receiving phones do not hang up (on their own) initially …
If you wait: about 25 seconds: the phones then do hang up (but it takes 25 seconds or so)

I’ve set a BLF button for 9000 on the phones, and this works …
But: after you’ve used the button: it stays RED on all phones for (25 seconds or so) until the other phones have hung-up.

NOTE:
Using other Yealink phones, under a FreePBX 2.11 build: the paging works as expected, and all phones hang up after the calling party finishes their short page (announcement).
We do not have the 25-second waiting and RED BLF light for the paging group.

Any thoughts?


(Itzik) #7

You should’ve mentioned that in your first post. It’s EOL.


(Jared Busch) #8

This is paging, and not intercom. This also directly conflicts with what you said previously.

But at this point, I don’t care. Because you have still not done what you were told to do.